summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-02-28 19:52:31 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-02-28 19:53:44 +0700
commit7f8afa355d54b7c5c3faf1a5332c7c94dc4db28a (patch)
treefb0fe0de1bd13f49eb9a6182b1197ea4ac969407 /dev-python/iocapture
parentapp-admin/gentoo-rsync-mirror-1.0-r5: add alpha keyword (diff)
downloadgentoo-7f8afa355d54b7c5c3faf1a5332c7c94dc4db28a.tar.gz
gentoo-7f8afa355d54b7c5c3faf1a5332c7c94dc4db28a.tar.bz2
gentoo-7f8afa355d54b7c5c3faf1a5332c7c94dc4db28a.zip
dev-python/iocapture: python3_6 added
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/iocapture')
-rw-r--r--dev-python/iocapture/iocapture-0.1.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/iocapture/iocapture-0.1.2-r1.ebuild b/dev-python/iocapture/iocapture-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..dfbf4f71c865
--- /dev/null
+++ b/dev-python/iocapture/iocapture-0.1.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: 521a8c56754f34ba6918b8bc4426f0b679be2186 $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Capture stdout,stderr easily"
+HOMEPAGE="https://pypi.python.org/pypi/iocapture/"
+SRC_URI="https://github.com/oinume/iocapture/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+LICENSE="MIT"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ ${RDEPEND}
+ )"
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}