summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/extras
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/extras')
-rw-r--r--dev-python/extras/Manifest1
-rw-r--r--dev-python/extras/extras-0.0.3.ebuild26
-rw-r--r--dev-python/extras/metadata.xml9
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/extras/Manifest b/dev-python/extras/Manifest
new file mode 100644
index 000000000000..5f95b344395e
--- /dev/null
+++ b/dev-python/extras/Manifest
@@ -0,0 +1 @@
+DIST extras-0.0.3.tar.gz 6231 SHA256 7a60d84cb661b477c41a5ea35e931ae93860af8cd259ecc0a38a32ef1ae9ffc0 SHA512 7b08d094717a27fbb522d49c0c538e98baccef6540216479d176b55b94f3f0b97c4b70ed48f3802a1bf08a58fe9a319a113d4ca04d9dadcb85e3a99bf7490a3c WHIRLPOOL a80db53c4b536d1a98c03237cc56607ca477619d1789a4a4c4795c843212eb1bdc64f0fe2a0ae1d4a4bab351ec68e07acb9ae494e537630ba841826116121d2c
diff --git a/dev-python/extras/extras-0.0.3.ebuild b/dev-python/extras/extras-0.0.3.ebuild
new file mode 100644
index 000000000000..d066a64c0dd5
--- /dev/null
+++ b/dev-python/extras/extras-0.0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Useful extra bits for Python that should be in the standard library"
+HOMEPAGE="https://github.com/testing-cabal/extras/ http://pypi.python.org/pypi/extras/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/testtools[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" ${PN}/tests/test_extras.py || die
+ einfo "test_extras passed under ${EPYTHON}"
+}
diff --git a/dev-python/extras/metadata.xml b/dev-python/extras/metadata.xml
new file mode 100644
index 000000000000..2a25cb3f7f8f
--- /dev/null
+++ b/dev-python/extras/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">extras</remote-id>
+ <remote-id type="github">testing-cabal/extras</remote-id>
+ </upstream>
+</pkgmetadata>