summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-11 20:53:17 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-11 22:18:33 +0100
commit0641d379b6a29c64e3383eb0fbbe930162665eae (patch)
tree733feaa2a37323c8b8d47fef682a796101f61621 /dev-python/django-cache-url
parentdev-python/tomlkit: Stabilize 0.8.0 ppc64, #833092 (diff)
downloadgentoo-0641d379b6a29c64e3383eb0fbbe930162665eae.tar.gz
gentoo-0641d379b6a29c64e3383eb0fbbe930162665eae.tar.bz2
gentoo-0641d379b6a29c64e3383eb0fbbe930162665eae.zip
dev-python/django-cache-url: Bump to 3.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-cache-url')
-rw-r--r--dev-python/django-cache-url/Manifest1
-rw-r--r--dev-python/django-cache-url/django-cache-url-3.3.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/django-cache-url/Manifest b/dev-python/django-cache-url/Manifest
index f72a815bb8a3..0210398f40ac 100644
--- a/dev-python/django-cache-url/Manifest
+++ b/dev-python/django-cache-url/Manifest
@@ -1 +1,2 @@
DIST django-cache-url-3.2.3.tar.gz 8198 BLAKE2B 19c91cdb519fea9c80e4d5e89ec9d340fb9193ec3891f6fbb42ba07cac26aba2bc69c00c65797f0f70c1a4590ff7be2037eebf3bf4589270e68afe289f74945c SHA512 d5b3653de755a668c33d28d66d38d938fef84d3acbfd726463c85a45c49a4d13bf880723226be2946ef7ea784e10623e164e448263893f779effc3eaf75c959f
+DIST django-cache-url-3.3.0.tar.gz 8319 BLAKE2B 28e627270baf5ea030bdcf098968644fd59551b1e974c7e08b396313c13bc48d4417c1e7b7c9942a1773b05d53c1b918177ef649ab088efcfa9ecf375b17ecac SHA512 fc01f3ef1e490146b911cff6f905c5257c8adbca57734a442d0d8e715c77d398fe07d3e47f043627eabc87f6f72153c2504873bf81d248c9da9183d6fe005069
diff --git a/dev-python/django-cache-url/django-cache-url-3.3.0.ebuild b/dev-python/django-cache-url/django-cache-url-3.3.0.ebuild
new file mode 100644
index 000000000000..db2055bbcc7b
--- /dev/null
+++ b/dev-python/django-cache-url/django-cache-url-3.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Use Cache URLs in your Django application"
+HOMEPAGE="https://github.com/epicserve/django-cache-url"
+SRC_URI="
+ https://github.com/epicserve/django-cache-url/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst README.rst )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e '/--cov/d' -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}