summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-17 09:46:08 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-17 11:10:16 +0300
commitcedd9e9694db8b62fee1a579b8f45e9f10c20e9b (patch)
tree411167ec54dbfaa354be8d5c93bb1758f6cfa90f /dev-python/dbfread
parentdev-libs/nspr: wire up tests (diff)
downloadgentoo-cedd9e9694db8b62fee1a579b8f45e9f10c20e9b.tar.gz
gentoo-cedd9e9694db8b62fee1a579b8f45e9f10c20e9b.tar.bz2
gentoo-cedd9e9694db8b62fee1a579b8f45e9f10c20e9b.zip
dev-python/dbfread: EAPI=8, PEP517, cleanup
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/dbfread')
-rw-r--r--dev-python/dbfread/dbfread-2.0.7-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/dbfread/dbfread-2.0.7-r1.ebuild b/dev-python/dbfread/dbfread-2.0.7-r1.ebuild
new file mode 100644
index 000000000000..116e2142b96c
--- /dev/null
+++ b/dev-python/dbfread/dbfread-2.0.7-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read DBF Files with Python"
+HOMEPAGE="https://github.com/olemb/dbfread https://pypi.org/project/dbfread/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ test? ( https://github.com/olemb/dbfread/archive/refs/tags/${PV}.tar.gz -> ${P}-src.tar.gz )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ dbfread/test_read_and_length.py::test_len
+ dbfread/test_read_and_length.py::test_list
+)
+
+python_prepare_all() {
+ sed -e 's|\[pytest\]|[tool:pytest]|' -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}