summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-14 08:03:49 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-14 08:26:34 +0100
commit562fd2a6a5783423af9ab953dcb4b5f7bcf45c55 (patch)
treecb66e8e64219b86fbc51d041f0b0d09c5b1b8eab /dev-python/csvkit
parentdev-python/responses: Bump to 0.25.0 (diff)
downloadgentoo-562fd2a6a5783423af9ab953dcb4b5f7bcf45c55.tar.gz
gentoo-562fd2a6a5783423af9ab953dcb4b5f7bcf45c55.tar.bz2
gentoo-562fd2a6a5783423af9ab953dcb4b5f7bcf45c55.zip
dev-python/csvkit: Bump to 1.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/csvkit')
-rw-r--r--dev-python/csvkit/Manifest1
-rw-r--r--dev-python/csvkit/csvkit-1.4.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/csvkit/Manifest b/dev-python/csvkit/Manifest
index 0ef838b63db1..a67213b1ebfb 100644
--- a/dev-python/csvkit/Manifest
+++ b/dev-python/csvkit/Manifest
@@ -1 +1,2 @@
DIST csvkit-1.3.0.tar.gz 3795356 BLAKE2B d750464b9c39ddb1456a59741b30a63bf59146732f937129c9913af3c660c52fb73721a174b5e7b9f8446525c5e70d3f0735e20686b82b2daaeed8a5fb3a30a1 SHA512 ab78359f47177490689dd3d98ff473c4919c49ed4f603208a72ee1bc6bcdbc4aedb179a1833a15c64dbc9465bf48156813ebb5fdfc52e8c463b2a489b4f789a0
+DIST csvkit-1.4.0.tar.gz 3796472 BLAKE2B 4501a320ab9b8f9f5642ea3957caddb024301a3a299fce17876562973874bad8305ce5cb8e879c7269d7b57d54e97e70f315728b52605a1059705111192874ad SHA512 5363fe8380c6ad1e44961bd7781feecd6fd19802a1c30144a45bdac364980413be3ac37e564491aca72c33d8b8a08dd5b49cfe2217b02bb5f3083db75996d687
diff --git a/dev-python/csvkit/csvkit-1.4.0.ebuild b/dev-python/csvkit/csvkit-1.4.0.ebuild
new file mode 100644
index 000000000000..fc3cd91b4609
--- /dev/null
+++ b/dev-python/csvkit/csvkit-1.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A suite of utilities for converting to and working with CSV"
+HOMEPAGE="
+ https://github.com/wireservice/csvkit/
+ https://pypi.org/project/csvkit/
+"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/agate-1.6.3[${PYTHON_USEDEP}]
+ >=dev-python/agate-excel-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/agate-dbf-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/agate-sql-0.5.3[${PYTHON_USEDEP}]
+ dev-python/openpyxl[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/xlrd[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails depending on locale, let's not force en_US
+ tests/test_utilities/test_csvstat.py::TestCSVStat::test_decimal_format
+ )
+ local -x LC_ALL=C.UTF-8
+ epytest
+}