summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-11 22:48:52 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-11 22:48:52 +0300
commit6b94429d147cc285df744b6dc52ff49b6d81b697 (patch)
tree5bcc1b8bf266e3f1e1f6495b0ac8318ba866b9e2 /dev-python/botocore
parentdev-python/reportlab: add 3.6.11 (diff)
downloadgentoo-6b94429d147cc285df744b6dc52ff49b6d81b697.tar.gz
gentoo-6b94429d147cc285df744b6dc52ff49b6d81b697.tar.bz2
gentoo-6b94429d147cc285df744b6dc52ff49b6d81b697.zip
dev-python/botocore: add 1.27.27
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.27.27.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index cbfe2d35ce6b..737fa9bdd74a 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.27.17.tar.gz 9130505 BLAKE2B 04c6b37f3b42a0f9fb696b5213338b004418a68c754f5027ad447119fb20556dc49bd53f40fd9560ea3f5bdcf2afbe151dba68e901079baec770f9f223b1a894 SHA512 b1a145d3c97adfd4df40639da99e1c34087508be189d5818ee7176f20454f2897a6f518a14b4bfbf41cb169a17188bec467337c10d0ad511e223f0c1ff5b64ee
DIST botocore-1.27.22.tar.gz 9151155 BLAKE2B e3aa6e9814e07bca2bd67d16f6548303af71654021b28f13c43b4005ba24a32cfccffa9a145babb781a6cbff9df3eab7de4c18973c00b3861ba83264eb144537 SHA512 57e43577840c62556760ff40d820898b0ee1efeb5da39fbdfe8c7ef53e86c8184bdfed5a52eeb9d0652fa053900462bdad9820b4a34bd4b5231f361b89c710d6
DIST botocore-1.27.26.tar.gz 9167551 BLAKE2B 9e95c1e6e5261b08247615446a589318d92cc86768c5e3999f99fb8e2a4a888309d72d4d3d66a1ebf9c1e2b6ccab6265a1d94ad9dcbf9da22aa1ae012aa2bfb3 SHA512 bbb563c2bc8eb3fe022f0b7be263ef16de93aadb02fb7a8e242f53a957a97e8f8b5d043ea8897a7b268d4d64b1e4972f2ccc91b8255f232c858f6a9ba1d93f34
+DIST botocore-1.27.27.tar.gz 9168895 BLAKE2B 71cc1d94a570110305a37c6813e626bf2c06189692af6a0c1c751f63b329fb13c41e048103b1938f680cf00d08b2c16d253fcee0d559716ccc411be4635f8741 SHA512 d974824a5f1d6bdf332c49682fede28b1b2c464928595929c5f7e8c2cbcdc8216cd590dfdf2dadffbd4cd21e1aeefc89744424e09eab876ad77280e6023b362f
diff --git a/dev-python/botocore/botocore-1.27.27.ebuild b/dev-python/botocore/botocore-1.27.27.ebuild
new file mode 100644
index 000000000000..830c713f6036
--- /dev/null
+++ b/dev-python/botocore/botocore-1.27.27.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}