summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlillypad <lillypadgirl86@gmail.com>2019-06-16 17:00:34 -0300
committerZac Medico <zmedico@gentoo.org>2019-06-30 14:57:06 -0700
commit3cb74f221facb32e91e2cde249f15a3fc3ce61f2 (patch)
tree5f618ec3c4ba3d2f6dbfa7ff41a83b86903e8ea1 /dev-python/billiard/billiard-3.6.0.0.ebuild
parentsci-mathematics/msieve: Remove gwnum USE dep (diff)
downloadgentoo-3cb74f221facb32e91e2cde249f15a3fc3ce61f2.tar.gz
gentoo-3cb74f221facb32e91e2cde249f15a3fc3ce61f2.tar.bz2
gentoo-3cb74f221facb32e91e2cde249f15a3fc3ce61f2.zip
dev-python/billiard: Bump to version 3.6.0.0
Bug: https://bugs.gentoo.org/688034 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Lilly Chalupowski <lillypadgirl86@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/billiard/billiard-3.6.0.0.ebuild')
-rw-r--r--dev-python/billiard/billiard-3.6.0.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/billiard/billiard-3.6.0.0.ebuild b/dev-python/billiard/billiard-3.6.0.0.ebuild
new file mode 100644
index 000000000000..087879f89dc1
--- /dev/null
+++ b/dev-python/billiard/billiard-3.6.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python multiprocessing fork"
+HOMEPAGE="https://pypi.org/project/billiard/ https://github.com/celery/billiard"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="
+ >=dev-python/setuptools-20.6.7[${PYTHON_USEDEP}]
+ test? (
+ !!<dev-python/celery-4.3.0
+ >=dev-python/case-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )"
+# The usual req'd for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx --builder="html" --source-dir=Doc/
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/sphinx/html/. )
+ distutils-r1_python_install_all
+}