summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-12-12 11:23:36 -0500
committerBrian Evans <grknight@gentoo.org>2016-12-12 11:23:36 -0500
commit343cbb430f4d2708be47c82c43b272aedaa7454f (patch)
tree938bad6558c4df6bd394c17c890e62cb8a66028f /dev-php/pecl-memcached/pecl-memcached-2.2.0-r2.ebuild
parentdev-php/igbinary: Revbump to add PHP 7.1 support flag (diff)
downloadgentoo-343cbb430f4d2708be47c82c43b272aedaa7454f.tar.gz
gentoo-343cbb430f4d2708be47c82c43b272aedaa7454f.tar.bz2
gentoo-343cbb430f4d2708be47c82c43b272aedaa7454f.zip
dev-php/pecl-memcached: Version bump with php 7.0 and 7.1
Taken from github snapshot commit, not yet released Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-php/pecl-memcached/pecl-memcached-2.2.0-r2.ebuild')
-rw-r--r--dev-php/pecl-memcached/pecl-memcached-2.2.0-r2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-php/pecl-memcached/pecl-memcached-2.2.0-r2.ebuild b/dev-php/pecl-memcached/pecl-memcached-2.2.0-r2.ebuild
new file mode 100644
index 000000000000..3646ffe05959
--- /dev/null
+++ b/dev-php/pecl-memcached/pecl-memcached-2.2.0-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PHP_EXT_NAME="memcached"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( ChangeLog README.markdown )
+
+USE_PHP="php5-6 php7-0"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php5-6"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Interface PHP with memcached via libmemcached library"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="+session igbinary json sasl"
+
+DEPEND="php_targets_php5-6? (
+ >=dev-libs/libmemcached-1.0[sasl?]
+ sys-libs/zlib
+ dev-lang/php:5.6[session?,json?]
+ igbinary? ( dev-php/igbinary[php_targets_php5-6?] )
+ )"
+RDEPEND="${DEPEND}"
+PDEPEND="php_targets_php7-0? ( dev-php/pecl-memcached:7[php_targets_php7-0] )"
+
+src_prepare(){
+ if use php_targets_php5-6 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS="--enable-memcached
+ $(use_enable session memcached-session)
+ $(use_enable sasl memcached-sasl)
+ $(use_enable json memcached-json)
+ $(use_enable igbinary memcached-igbinary)"
+
+ php-ext-source-r3_src_configure
+}
+
+src_install() {
+ if use php_targets_php5-6 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}