summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-05-30 14:50:49 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-05-30 15:08:53 +0200
commit0f137461dbf0a9d09d67f597ec5060a5079f6471 (patch)
tree0d8bf90c07582ec0d31c119c455fddd7cf17f187 /dev-ml/ocamlfuse
parentsys-kernel/gentoo-sources: add 6.9.3, remove redundant patch (diff)
downloadgentoo-0f137461dbf0a9d09d67f597ec5060a5079f6471.tar.gz
gentoo-0f137461dbf0a9d09d67f597ec5060a5079f6471.tar.bz2
gentoo-0f137461dbf0a9d09d67f597ec5060a5079f6471.zip
dev-ml/ocamlfuse: -Wint-conversion
Closes: https://bugs.gentoo.org/932194 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ocamlfuse')
-rw-r--r--dev-ml/ocamlfuse/files/ocamlfuse-2.7.1_p7-Wint.patch11
-rw-r--r--dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild7
2 files changed, 16 insertions, 2 deletions
diff --git a/dev-ml/ocamlfuse/files/ocamlfuse-2.7.1_p7-Wint.patch b/dev-ml/ocamlfuse/files/ocamlfuse-2.7.1_p7-Wint.patch
new file mode 100644
index 000000000000..94df1c01546a
--- /dev/null
+++ b/dev-ml/ocamlfuse/files/ocamlfuse-2.7.1_p7-Wint.patch
@@ -0,0 +1,11 @@
+--- a/lib/Fuse_util.c 2024-05-30 14:46:19.594917120 +0200
++++ b/lib/Fuse_util.c 2024-05-30 14:46:39.870690546 +0200
+@@ -354,7 +354,7 @@
+
+ #define init_ARGS (struct fuse_conn_info *conn)
+ #define init_CALL_ARGS (conn)
+-#define init_RTYPE void *
++#define init_RTYPE int
+ #define init_CB vres=callback(*init_closure,Val_unit);
+ /* TODO: the result from init is wrong, it should return unit */
+ #define init_RES
diff --git a/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild b/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild
index 63891abc2fe4..ec2cd36592e8 100644
--- a/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild
+++ b/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -31,7 +31,10 @@ BDEPEND="
dev-ml/opam
"
-PATCHES=( "${FILESDIR}"/${P}-unistd.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-unistd.patch
+ "${FILESDIR}"/${P}-Wint.patch
+)
src_compile() {
tc-export CPP