summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyang Wu <xgreenlandforwyy@gmail.com>2023-01-27 20:28:34 +0800
committerSam James <sam@gentoo.org>2023-02-08 04:17:36 +0000
commitbbff88f734f62381b0a0624b4b2d182a8d4b8589 (patch)
tree41f85245d079828683ac96a1e1e6970005be81b0 /dev-libs/rocr-runtime
parentdev-util/roctracer: strip -Werror and fix a configure issue (diff)
downloadgentoo-bbff88f734f62381b0a0624b4b2d182a8d4b8589.tar.gz
gentoo-bbff88f734f62381b0a0624b4b2d182a8d4b8589.tar.bz2
gentoo-bbff88f734f62381b0a0624b4b2d182a8d4b8589.zip
dev-libs/rocr-runtime: disable non-FHS install
Closes: https://bugs.gentoo.org/887377 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime')
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-5.3.3.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-libs/rocr-runtime/rocr-runtime-5.3.3.ebuild b/dev-libs/rocr-runtime/rocr-runtime-5.3.3.ebuild
index 5004f492f993..99184725f576 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-5.3.3.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-5.3.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -47,3 +47,8 @@ src_prepare() {
cmake_src_prepare
}
+
+src_configure() {
+ local mycmakeargs=( -DINCLUDE_PATH_COMPATIBILITY=OFF )
+ cmake_src_configure
+}