summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-27 19:47:34 +0000
committerSam James <sam@gentoo.org>2024-02-27 21:44:43 +0000
commitb4af5d61d9614390f99d9d0cc39f28ad728d5413 (patch)
treedf09fd20834b95e7ea7c1005508763ce187fd324 /dev-libs/libbsd
parentwww-client/chromium: add 122.0.6261.69, drop 122.0.6261.57 (diff)
downloadgentoo-b4af5d61d9614390f99d9d0cc39f28ad728d5413.tar.gz
gentoo-b4af5d61d9614390f99d9d0cc39f28ad728d5413.tar.bz2
gentoo-b4af5d61d9614390f99d9d0cc39f28ad728d5413.zip
dev-libs/libbsd: add 0.12.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libbsd')
-rw-r--r--dev-libs/libbsd/Manifest2
-rw-r--r--dev-libs/libbsd/libbsd-0.12.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/libbsd/Manifest b/dev-libs/libbsd/Manifest
index 0a58f706b583..6125418b4a75 100644
--- a/dev-libs/libbsd/Manifest
+++ b/dev-libs/libbsd/Manifest
@@ -2,3 +2,5 @@ DIST libbsd-0.11.7.tar.xz 418508 BLAKE2B 2ff0aa951c5b37a58ab101aade52d077d52f369
DIST libbsd-0.11.7.tar.xz.asc 833 BLAKE2B 925cd4f5b68c0dccceb476cb188bb5a8185ad77895b9b458ff6819ae241dbd8cbf1c18dd12d10b90b3a9ea3f9e065b44566d1a908d0c111ecbd435434b922a66 SHA512 bdcce69ee261039900896c5be48659f1b6b809f3a6e8a5220aac30a6687926ac29e478a3ea737727d077d6575ee11b86eed896932568fdd261a9aaeb46d695b6
DIST libbsd-0.11.8.tar.xz 432376 BLAKE2B b2b9496423f177af7cba3c55c071b58a314ad987bd04fee5c93dc1885a501a923048f676d00dcb70c8cfa37de775c6ec64224dfecce1d0eaed50b8c27ec0c001 SHA512 0173fc20e2471f96bc6677500a02fbccef7463e023445f47681843c9a94b1fa9970c5af7d2f87f1a1e7f8a7bb60112988defc073828fd2a0dcd0e66e44e67295
DIST libbsd-0.11.8.tar.xz.asc 931 BLAKE2B 3841b81fa8bcdf0e27a41c769691dbefbb82073a18e3a30580794e0242c903bd0b512d31d6e897f8fa98ef3a3cf0dc08a413040ead00caa63f0b993396e1f2fe SHA512 a24355f9151f1da62e1f4f37280eec57ee7a32205b493d973d59231382c878e4373d4cf83ec41612536ef9361fe43e68331217c96c59b6741e7827272369ff2c
+DIST libbsd-0.12.0.tar.xz 443828 BLAKE2B cdc618303c9bcda59f4d75913e101677bfaecfe4377b9b6e9fbfa291098324c323653964350ff7ede71600e8720af80fd90c712fced11276c51ded4b4fe96fa6 SHA512 c742ce9dff4186dae11cdd779f450aa04feefa28eeec0938ad08031aa52f228cf5506cf15dbbf0ce3c00a2bee595496603e2a58551af5c2282c5cef3482f15c6
+DIST libbsd-0.12.0.tar.xz.asc 833 BLAKE2B 8437ae78b64c74815fa9518ad81cbaf2ec656d6b25f2a4b8d297cdb86c18474baaa5075742ad72b13cbb63f89530dc076b0d159cb9dc2d3762d1d739a3070cca SHA512 0b619be8cd292810be9b71b5f4e041709ddfbcb0189353abdb1f966ee5f662c028131897e30581a9dec727d2d9682304efbd51cb70ac60514fbeae2e338dd13d
diff --git a/dev-libs/libbsd/libbsd-0.12.0.ebuild b/dev-libs/libbsd/libbsd-0.12.0.ebuild
new file mode 100644
index 000000000000..597b8dad0029
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.12.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/guillemjover.asc
+inherit flag-o-matic multilib multilib-minimal verify-sig
+
+DESCRIPTION="Library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="https://libbsd.freedesktop.org/wiki/ https://gitlab.freedesktop.org/libbsd/libbsd"
+SRC_URI="https://${PN}.freedesktop.org/releases/${P}.tar.xz"
+SRC_URI+=" verify-sig? ( https://${PN}.freedesktop.org/releases/${P}.tar.xz.asc )"
+
+LICENSE="BEER-WARE BSD BSD-2 BSD-4 ISC MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="app-crypt/libmd[${MULTILIB_USEDEP}]"
+DEPEND="
+ ${RDEPEND}
+ >=sys-kernel/linux-headers-3.17
+"
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-guillemjover )"
+
+MULTILIB_WRAPPED_HEADERS=(
+ # Diverges for time64
+ /usr/include/bsd/sys/cdefs.h
+)
+
+multilib_src_configure() {
+ # bug #911726
+ filter-flags -fno-semantic-interposition
+
+ # The build system will install libbsd-ctor.a despite USE="-static-libs"
+ # which is correct, see:
+ # https://gitlab.freedesktop.org/libbsd/libbsd/commit/c5b959028734ca2281250c85773d9b5e1d259bc8
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ find "${ED}" -type f -name "*.la" -delete || die
+
+ # ld scripts on standalone prefix (RAP) systems should have the prefix
+ # stripped from any paths, as the sysroot is automatically prepended.
+ local ldscript=${ED}/usr/$(get_libdir)/${PN}$(get_libname)
+ if use prefix && ! use prefix-guest && grep -qIF "ld script" "${ldscript}" 2>/dev/null; then
+ sed -i "s|${EPREFIX}/|/|g" "${ldscript}" || die
+ fi
+}