summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-12-17 18:07:05 +0000
committerMarek Szuba <marecki@gentoo.org>2021-12-17 18:11:33 +0000
commited0b08e35f37cd3e3ea427e2850617c05353d78e (patch)
tree5e4cf618a38a3e4bad4527fa2288d2817638d47b /dev-libs/isa-l
parentnet-analyzer/fail2ban: enable py3.10 (diff)
downloadgentoo-ed0b08e35f37cd3e3ea427e2850617c05353d78e.tar.gz
gentoo-ed0b08e35f37cd3e3ea427e2850617c05353d78e.tar.bz2
gentoo-ed0b08e35f37cd3e3ea427e2850617c05353d78e.zip
dev-libs/isa-l: initial import
Required by erasure-coding features of net-libs/xrootd - or rather WILL BE required, as at the moment the latter seems to have no option to use a system-installed version. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-libs/isa-l')
-rw-r--r--dev-libs/isa-l/Manifest1
-rw-r--r--dev-libs/isa-l/files/isa-l-2.30.0_makefile-no-D.patch16
-rw-r--r--dev-libs/isa-l/isa-l-2.30.0.ebuild33
-rw-r--r--dev-libs/isa-l/metadata.xml21
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-libs/isa-l/Manifest b/dev-libs/isa-l/Manifest
new file mode 100644
index 000000000000..6f03ccf55882
--- /dev/null
+++ b/dev-libs/isa-l/Manifest
@@ -0,0 +1 @@
+DIST isa-l-2.30.0.tar.gz 649389 BLAKE2B 3364733d61ce16c91891b6da63d2b4fb2bc004761c91f2076a9a6441adaea24af43b6d32caec011c06206e3811e8c9639f8ceaac89fe97800144c7f78c80c350 SHA512 d3ecfb7326097534b06a74b584100336509525ae7cadc6112d0c27e3d8704f3810e18f583d3cc33fa266bfec96db023607622b22ddbf17988ec4bf1bb3b3b9b2
diff --git a/dev-libs/isa-l/files/isa-l-2.30.0_makefile-no-D.patch b/dev-libs/isa-l/files/isa-l-2.30.0_makefile-no-D.patch
new file mode 100644
index 000000000000..98c37f3cc42f
--- /dev/null
+++ b/dev-libs/isa-l/files/isa-l-2.30.0_makefile-no-D.patch
@@ -0,0 +1,16 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -142,11 +142,11 @@
+ EXTRA_DIST += tools/yasm-filter.sh tools/nasm-filter.sh
+ EXTRA_DIST += tools/yasm-cet-filter.sh tools/nasm-cet-filter.sh
+
+-AM_CFLAGS = ${my_CFLAGS} ${INCLUDE} $(src_include) ${D}
++AM_CFLAGS = ${my_CFLAGS} ${INCLUDE} $(src_include) ${DIST_D}
+ if CPU_AARCH64
+ AM_CCASFLAGS = ${AM_CFLAGS}
+ else
+-AM_CCASFLAGS = ${yasm_args} ${INCLUDE} ${src_include} ${DEFS} ${D}
++AM_CCASFLAGS = ${yasm_args} ${INCLUDE} ${src_include} ${DEFS} ${DIST_D}
+ endif
+
+ .asm.s:
diff --git a/dev-libs/isa-l/isa-l-2.30.0.ebuild b/dev-libs/isa-l/isa-l-2.30.0.ebuild
new file mode 100644
index 000000000000..641f57997e4b
--- /dev/null
+++ b/dev-libs/isa-l/isa-l-2.30.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Intelligent Storage Acceleration Library"
+HOMEPAGE="https://github.com/intel/isa-l"
+SRC_URI="https://github.com/intel/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+#DEPEND=""
+#RDEPEND=""
+# TODO: yasm version to support avx512?
+BDEPEND="amd64? ( >=dev-lang/nasm-2.15 )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.30.0_makefile-no-D.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/isa-l/metadata.xml b/dev-libs/isa-l/metadata.xml
new file mode 100644
index 000000000000..79b2a15f343d
--- /dev/null
+++ b/dev-libs/isa-l/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription>
+ ISA-L is a collection of optimized low-level functions targeting storage applications. ISA-L includes:
+ * Erasure codes - Fast block Reed-Solomon type erasure codes for any encode/decode matrix in GF(2^8).
+ * CRC - Fast implementations of cyclic redundancy check. Six different polynomials supported.
+ * iscsi32, ieee32, t10dif, ecma64, iso64, jones64.
+ * Raid - calculate and operate on XOR and P+Q parity found in common RAID implementations.
+ * Compression - Fast deflate-compatible data compression.
+ * De-compression - Fast inflate-compatible data compression.
+ * igzip - A command line application like gzip, accelerated with ISA-L.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">intel/isa-l</remote-id>
+ </upstream>
+</pkgmetadata>