summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandall T. Vasquez <ran.dall@icloud.com>2023-03-15 18:08:17 -0700
committerConrad Kostecki <conikost@gentoo.org>2023-04-18 15:40:54 +0200
commit4d6980df2d445291d61ceceb5a3597570aec1112 (patch)
tree94291adafb20b0d74083ba6f9410dee68cf2aba8 /dev-libs/appstream
parentapp-office/ledger: remove unused patch(es) (diff)
downloadgentoo-4d6980df2d445291d61ceceb5a3597570aec1112.tar.gz
gentoo-4d6980df2d445291d61ceceb5a3597570aec1112.tar.bz2
gentoo-4d6980df2d445291d61ceceb5a3597570aec1112.zip
dev-libs/appstream: add 0.16.1
Signed-off-by: Randall T. Vasquez <ran.dall@icloud.com> Closes: https://github.com/gentoo/gentoo/pull/30159 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/appstream')
-rw-r--r--dev-libs/appstream/Manifest1
-rw-r--r--dev-libs/appstream/appstream-0.16.1.ebuild77
-rw-r--r--dev-libs/appstream/files/appstream-0.16.1-disable-Werror-flags.patch50
3 files changed, 128 insertions, 0 deletions
diff --git a/dev-libs/appstream/Manifest b/dev-libs/appstream/Manifest
index 2e213f107408..ab274e663f0d 100644
--- a/dev-libs/appstream/Manifest
+++ b/dev-libs/appstream/Manifest
@@ -1 +1,2 @@
DIST AppStream-0.15.6.tar.xz 2517688 BLAKE2B 09519205c7dfc5f0715b9d5ae7e99a67673ab499f1e2cb39815edde64defc1aa5059215575278bbcfc4482cd385a79e081c70f6acea3c446c5869dc6b2e18f6c SHA512 7426bc89e22b751de7b3e27d7c07eb1c373f4439f9966868ce5ea410d209b8c5292e03695a34b7a49bfa61e2e62265c7f7cdffc0be871c950193c933f65757ef
+DIST AppStream-0.16.1.tar.xz 2558188 BLAKE2B 78d19fd3dc6f443fc6f130f9053cb4a32b1592766e3b076ad965845ee29038fec545cd13728724f49f372cf63fafce6b536e649dc1d266342f66095d37cb2514 SHA512 79e139bd0f54534aa37c21d24309c33ee936e737149d6fa5ba0ec50e8ade33c2951d0b1e2ff15729e2a4d274ff1f7ca734bb70efa94539d87a3f949a07fb7d9e
diff --git a/dev-libs/appstream/appstream-0.16.1.ebuild b/dev-libs/appstream/appstream-0.16.1.ebuild
new file mode 100644
index 000000000000..22035505fdee
--- /dev/null
+++ b/dev-libs/appstream/appstream-0.16.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg-utils
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ximion/${PN}"
+else
+ MY_PN="AppStream"
+ SRC_URI="https://www.freedesktop.org/software/appstream/releases/${MY_PN}-${PV}.tar.xz"
+ KEYWORDS="amd64 ~arm arm64 ~loong ~ppc ~ppc64 ~riscv x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Cross-distro effort for providing metadata for software in the Linux ecosystem"
+HOMEPAGE="https://www.freedesktop.org/wiki/Distributions/AppStream/"
+
+LICENSE="LGPL-2.1+ GPL-2+"
+# check as_api_level
+SLOT="0/4"
+IUSE="apt doc +introspection qt5 test"
+RESTRICT="test" # bug 691962
+
+RDEPEND="
+ >=dev-libs/glib-2.62:2
+ dev-libs/libxml2:2
+ >=dev-libs/libxmlb-0.3.6:=
+ dev-libs/libyaml
+ dev-libs/snowball-stemmer:=
+ >=net-misc/curl-7.62
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+ qt5? ( dev-qt/qtcore:5 )
+"
+DEPEND="${RDEPEND}
+ test? ( qt5? ( dev-qt/qttest:5 ) )
+"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxslt
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ doc? ( app-text/docbook-xml-dtd:4.5 )
+ test? ( dev-qt/linguist-tools:5 )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-disable-Werror-flags.patch ) # bug 733774
+
+src_prepare() {
+ default
+ sed -e "/^as_doc_target_dir/s/appstream/${PF}/" -i docs/meson.build || die
+ if ! use test; then
+ sed -e "/^subdir.*tests/s/^/#DONT /" -i {,qt/}meson.build || die # bug 675944
+ fi
+}
+
+src_configure() {
+ xdg_environment_reset
+
+ local emesonargs=(
+ -Dapidocs=false
+ -Ddocs=false
+ -Dcompose=false
+ -Dmaintainer=false
+ -Dstatic-analysis=false
+ -Dstemming=true
+ -Dvapi=false
+ -Dapt-support=$(usex apt true false)
+ -Dinstall-docs=$(usex doc true false)
+ -Dgir=$(usex introspection true false)
+ -Dqt=$(usex qt5 true false)
+ )
+
+ meson_src_configure
+}
diff --git a/dev-libs/appstream/files/appstream-0.16.1-disable-Werror-flags.patch b/dev-libs/appstream/files/appstream-0.16.1-disable-Werror-flags.patch
new file mode 100644
index 000000000000..e42c88e3bd31
--- /dev/null
+++ b/dev-libs/appstream/files/appstream-0.16.1-disable-Werror-flags.patch
@@ -0,0 +1,50 @@
+--- a/meson.build 2023-03-15 14:18:16.657101983 -0700
++++ b/meson.build 2023-03-15 14:21:20.055049626 -0700
+@@ -97,47 +97,6 @@
+ endif
+ endif
+
+-# a few compiler warning flags we always want enabled
+-add_project_arguments(
+- cc.get_supported_arguments([
+- '-Werror=shadow',
+- '-Werror=empty-body',
+- '-Werror=strict-prototypes',
+- '-Werror=missing-prototypes',
+- '-Werror=implicit-function-declaration',
+- '-Werror=pointer-arith',
+- '-Werror=missing-declarations',
+- '-Werror=return-type',
+- '-Werror=int-conversion',
+- '-Werror=incompatible-pointer-types',
+- '-Werror=misleading-indentation',
+- '-Werror=missing-include-dirs',
+- '-Werror=declaration-after-statement',
+- '-Werror=format-security',
+-
+- '-Wno-missing-field-initializers',
+- '-Wno-error=missing-field-initializers',
+- '-Wno-unused-parameter',
+- '-Wno-error=unused-parameter',
+- ]),
+- language: 'c'
+-)
+-add_project_arguments(
+- '-Wno-unused-parameter',
+- '-Werror=shadow',
+- '-Werror=empty-body',
+- '-Werror=pointer-arith',
+- '-Werror=init-self',
+- '-Werror=missing-declarations',
+- '-Werror=return-type',
+- '-Werror=misleading-indentation',
+- '-Werror=format-security',
+-
+- # NOTE: Can be removed with AppStream 1.0
+- '-Wno-error=c++20-compat',
+- language: 'cpp'
+-)
+-
+ # Vendor extensions in system headers
+ add_project_arguments('-D_POSIX_C_SOURCE=200809L', language: 'c')
+