summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-25 23:50:06 +0000
committerSam James <sam@gentoo.org>2022-03-26 00:00:43 +0000
commit2630992d7e26838c190192b06fbdb3d6b6921ac8 (patch)
tree108d152c2ee5a527aa840b8784ac904ba52b379e /dev-lang/crystal
parentnet-proxy/haproxy: fix ERROT typo -> ESYSROOT (diff)
downloadgentoo-2630992d7e26838c190192b06fbdb3d6b6921ac8.tar.gz
gentoo-2630992d7e26838c190192b06fbdb3d6b6921ac8.tar.bz2
gentoo-2630992d7e26838c190192b06fbdb3d6b6921ac8.zip
dev-lang/crystal: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/crystal')
-rw-r--r--dev-lang/crystal/crystal-1.1.0.ebuild8
-rw-r--r--dev-lang/crystal/crystal-1.1.1.ebuild8
-rw-r--r--dev-lang/crystal/crystal-1.2.1.ebuild8
-rw-r--r--dev-lang/crystal/crystal-1.2.2.ebuild8
4 files changed, 16 insertions, 16 deletions
diff --git a/dev-lang/crystal/crystal-1.1.0.ebuild b/dev-lang/crystal/crystal-1.1.0.ebuild
index 7af64a711416..a435a4600025 100644
--- a/dev-lang/crystal/crystal-1.1.0.ebuild
+++ b/dev-lang/crystal/crystal-1.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -70,9 +70,9 @@ src_compile() {
threads=$(makeopts_jobs) \
verbose=1 \
\
- CC=$(tc-getCC) \
- CXX=$(tc-getCXX) \
- AR=$(tc-getAR) \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ AR="$(tc-getAR)" \
LLVM_CONFIG="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/bin/llvm-config" \
\
PATH="${bootstrap_path}:${PATH}" \
diff --git a/dev-lang/crystal/crystal-1.1.1.ebuild b/dev-lang/crystal/crystal-1.1.1.ebuild
index 5917510958e7..f21d7749e7a5 100644
--- a/dev-lang/crystal/crystal-1.1.1.ebuild
+++ b/dev-lang/crystal/crystal-1.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -62,9 +62,9 @@ src_configure() {
stats=1
threads=$(makeopts_jobs)
verbose=1
- CC=$(tc-getCC)
- CXX=$(tc-getCXX)
- AR=$(tc-getAR)
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ AR="$(tc-getAR)"
LLVM_CONFIG="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/bin/llvm-config"
PATH="${bootstrap_path}:${PATH}"
CRYSTAL_PATH=src
diff --git a/dev-lang/crystal/crystal-1.2.1.ebuild b/dev-lang/crystal/crystal-1.2.1.ebuild
index 6e531f8dcf46..7758bb838f9a 100644
--- a/dev-lang/crystal/crystal-1.2.1.ebuild
+++ b/dev-lang/crystal/crystal-1.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -59,9 +59,9 @@ src_configure() {
stats=1
threads=$(makeopts_jobs)
verbose=1
- CC=$(tc-getCC)
- CXX=$(tc-getCXX)
- AR=$(tc-getAR)
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ AR="$(tc-getAR)"
LLVM_CONFIG="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/bin/llvm-config"
PATH="${bootstrap_path}:${PATH}"
CRYSTAL_PATH=src
diff --git a/dev-lang/crystal/crystal-1.2.2.ebuild b/dev-lang/crystal/crystal-1.2.2.ebuild
index 6e531f8dcf46..7758bb838f9a 100644
--- a/dev-lang/crystal/crystal-1.2.2.ebuild
+++ b/dev-lang/crystal/crystal-1.2.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -59,9 +59,9 @@ src_configure() {
stats=1
threads=$(makeopts_jobs)
verbose=1
- CC=$(tc-getCC)
- CXX=$(tc-getCXX)
- AR=$(tc-getAR)
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ AR="$(tc-getAR)"
LLVM_CONFIG="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/bin/llvm-config"
PATH="${bootstrap_path}:${PATH}"
CRYSTAL_PATH=src