summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/snakeyaml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/snakeyaml')
-rw-r--r--dev-java/snakeyaml/Manifest2
-rw-r--r--dev-java/snakeyaml/metadata.xml10
-rw-r--r--dev-java/snakeyaml/snakeyaml-1.11.ebuild37
-rw-r--r--dev-java/snakeyaml/snakeyaml-1.9-r1.ebuild36
-rw-r--r--dev-java/snakeyaml/snakeyaml-1.9.ebuild36
5 files changed, 121 insertions, 0 deletions
diff --git a/dev-java/snakeyaml/Manifest b/dev-java/snakeyaml/Manifest
new file mode 100644
index 000000000000..9efae9b08ef9
--- /dev/null
+++ b/dev-java/snakeyaml/Manifest
@@ -0,0 +1,2 @@
+DIST SnakeYAML-all-1.11.zip 11972014 SHA256 dcca58023e8c40cd9b29513f2970791181e71e304c127e99d378fba70ebd7d40 SHA512 f454a8d99b8e08858b64d3ca13443f7934f92e31fb5e1fd57147dc957827ed4278275b201ad7a739eeebf8ee6b70669dc13d3994a876c22f09c7f1d8f312b941 WHIRLPOOL 0796ca3f5314efa6b2c48080acdcbf5c9989bee6d6d68e4a2df8dba4551a767de2f1b9a451ff49abf6daa61b33bcb7cb08f2985846dc97118d845968159e068c
+DIST SnakeYAML-all-1.9.zip 9122570 SHA256 7c1090eb1b2e06f784dc424678f18d513dfe020fd2f0042c63217e09ae9a8853 SHA512 8b2fd5de8374b592b74f52cea66cbb7aed04892fecf7f994fc797fc9fdb185fed4fa02a1fe69e69f137acb01037f77ed18988b83d038bc425fa04186947dab19 WHIRLPOOL f7a9dcd644638b28a35a8a33d81455984455d1b55dddc057db17cb6e60589240331ab2beb56df4f6a81bbe6ff1fe2b63731eff6454b601b1a76ba5c2061baa7c
diff --git a/dev-java/snakeyaml/metadata.xml b/dev-java/snakeyaml/metadata.xml
new file mode 100644
index 000000000000..8c290ebcf0ab
--- /dev/null
+++ b/dev-java/snakeyaml/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="google-code">snakeyaml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/snakeyaml/snakeyaml-1.11.ebuild b/dev-java/snakeyaml/snakeyaml-1.11.ebuild
new file mode 100644
index 000000000000..0451fb4ec7c3
--- /dev/null
+++ b/dev-java/snakeyaml/snakeyaml-1.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A YAML 1.1 parser and emitter for Java 5"
+HOMEPAGE="http://code.google.com/p/snakeyaml/"
+SRC_URI="http://snakeyaml.googlecode.com/files/SnakeYAML-all-${PV}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/${PN}"
+
+JAVA_SRC_DIR="src/main/java"
+
+java_prepare() {
+ find "${WORKDIR}" -name '*.class' -exec rm {} +
+
+ # Easier to use java-pkg-simple.
+ rm -v pom.xml || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+
+ dodoc AUTHORS src/etc/announcement.msg
+}
diff --git a/dev-java/snakeyaml/snakeyaml-1.9-r1.ebuild b/dev-java/snakeyaml/snakeyaml-1.9-r1.ebuild
new file mode 100644
index 000000000000..ae5e9457ef19
--- /dev/null
+++ b/dev-java/snakeyaml/snakeyaml-1.9-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A YAML 1.1 parser and emitter for Java 5"
+HOMEPAGE="http://code.google.com/p/snakeyaml/"
+SRC_URI="http://snakeyaml.googlecode.com/files/SnakeYAML-all-${PV}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="1.9"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/${PN}"
+JAVA_SRC_DIR="src/main/java"
+
+java_prepare() {
+ find "${WORKDIR}" -name '*.class' -exec rm {} +
+
+ # Easier to use java-pkg-simple.
+ rm -v pom.xml || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc AUTHORS src/etc/announcement.msg
+}
diff --git a/dev-java/snakeyaml/snakeyaml-1.9.ebuild b/dev-java/snakeyaml/snakeyaml-1.9.ebuild
new file mode 100644
index 000000000000..1e56652b1d65
--- /dev/null
+++ b/dev-java/snakeyaml/snakeyaml-1.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A YAML 1.1 parser and emitter for Java 5"
+HOMEPAGE="http://code.google.com/p/snakeyaml/"
+SRC_URI="http://snakeyaml.googlecode.com/files/SnakeYAML-all-${PV}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/${PN}"
+JAVA_SRC_DIR="src/main/java"
+
+java_prepare() {
+ find "${WORKDIR}" -name '*.class' -exec rm {} +
+
+ # Easier to use java-pkg-simple.
+ rm -v pom.xml || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc AUTHORS src/etc/announcement.msg
+}