summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jikes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jikes')
-rw-r--r--dev-java/jikes/Manifest1
-rw-r--r--dev-java/jikes/files/compiler-settings6
-rw-r--r--dev-java/jikes/files/deprecated.patch25
-rw-r--r--dev-java/jikes/files/jikes16
-rw-r--r--dev-java/jikes/jikes-1.22-r13.ebuild38
-rw-r--r--dev-java/jikes/metadata.xml8
6 files changed, 94 insertions, 0 deletions
diff --git a/dev-java/jikes/Manifest b/dev-java/jikes/Manifest
new file mode 100644
index 000000000000..90ddb1822d10
--- /dev/null
+++ b/dev-java/jikes/Manifest
@@ -0,0 +1 @@
+DIST jikes-1.22.tar.bz2 616655 SHA256 0cb02c763bc441349f6d38cacd52adf762302cce3a08e269f1f75f726e6e14e3 SHA512 6b318f49f075da0cf0558512748bd77072f5b5b0428160538bcba01201c94719ec0f4b0cd0159ddb04fb3a86c323c8f11f09dc4b31cf880fb94e00c1ee0bbc58 WHIRLPOOL 1c97d130c72933d2eb302e3de782f33c0ef2ca59377df554b6391f6eece41d7142a8652d9e9b5e49e0ab134dc7223793b7ef1f67c0fe2ad787993587a87855aa
diff --git a/dev-java/jikes/files/compiler-settings b/dev-java/jikes/files/compiler-settings
new file mode 100644
index 000000000000..0e50102cd2ef
--- /dev/null
+++ b/dev-java/jikes/files/compiler-settings
@@ -0,0 +1,6 @@
+JAVAC=/usr/bin/jikes
+PACKAGE=dev-java/jikes
+SUPPORTED_TARGET="1.1 1.2 1.3 1.4"
+SUPPORTED_SOURCE="1.3 1.4"
+ANT_BUILD_COMPILER="jikes"
+GENERATION="2"
diff --git a/dev-java/jikes/files/deprecated.patch b/dev-java/jikes/files/deprecated.patch
new file mode 100644
index 000000000000..0fd05253a6df
--- /dev/null
+++ b/dev-java/jikes/files/deprecated.patch
@@ -0,0 +1,25 @@
+--- src/decl.cpp 2004/09/26 22:40:411.144
++++ src/decl.cpp 2004/10/09 18:04:501.145
+@@ -2596,7 +2596,9 @@
+ //
+ if (control.option.deprecation &&
+ hidden_method -> IsDeprecated() &&
+- ! method -> containing_type -> file_symbol -> IsClassOnly())
++ ! method -> containing_type -> file_symbol -> IsClassOnly() &&
++ ! method -> IsDeprecated() &&
++ ! InDeprecatedContext())
+ {
+ ReportSemError(SemanticError::DEPRECATED_METHOD_OVERRIDE,
+ left_tok, right_tok, method -> Header(),
+
+diff -u -r1.159 -r1.160
+--- src/error.cpp 2004/09/26 22:40:411.159
++++ src/error.cpp 2004/10/10 02:59:401.160
+@@ -513,6 +513,7 @@
+ warning[DEPRECATED_FIELD] = WEAK_WARNING;
+ warning[DEPRECATED_METHOD] = WEAK_WARNING;
+ warning[DEPRECATED_CONSTRUCTOR] = WEAK_WARNING;
++ warning[DEPRECATED_METHOD_OVERRIDE] = WEAK_WARNING;
+
+ warning[UNNECESSARY_TYPE_IMPORT] = WEAK_WARNING;
+ warning[MULTIPLE_PUBLIC_TYPES] = WEAK_WARNING;
diff --git a/dev-java/jikes/files/jikes b/dev-java/jikes/files/jikes
new file mode 100644
index 000000000000..e80c048614df
--- /dev/null
+++ b/dev-java/jikes/files/jikes
@@ -0,0 +1,16 @@
+#!/bin/bash
+#
+# Copyright (c) 2005, Thomas Matthijs <axxo@gentoo.org>
+# Copyright (c) 2005, Gentoo Foundation
+#
+# Licensed under the GNU General Public License, v2.
+#
+
+[[ -z ${BOOTCLASSPATH} ]] && export BOOTCLASSPATH=$(java-config-2 --runtime)
+
+if [[ -z "${BOOTCLASSPATH}" ]]; then
+ echo "!!! Could not find runtime classes" > /dev/stderr
+ exit 2
+fi
+
+exec /usr/bin/jikes-bin "$@"
diff --git a/dev-java/jikes/jikes-1.22-r13.ebuild b/dev-java/jikes/jikes-1.22-r13.ebuild
new file mode 100644
index 000000000000..1405cab6ca79
--- /dev/null
+++ b/dev-java/jikes/jikes-1.22-r13.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="IBM's open source, high performance Java compiler"
+HOMEPAGE="http://jikes.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="IBM"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+DEPEND=""
+RDEPEND=">=dev-java/java-config-2.0.0"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/deprecated.patch
+}
+
+src_compile() {
+ filter-flags "-fno-rtti"
+ econf || die "configure problem"
+ emake || die "compile problem"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "install problem"
+ dodoc ChangeLog AUTHORS README TODO NEWS
+
+ mv "${D}"/usr/bin/jikes{,-bin}
+ dobin "${FILESDIR}"/jikes
+
+ insinto /usr/share/java-config-2/compiler
+ newins "${FILESDIR}"/compiler-settings jikes
+}
diff --git a/dev-java/jikes/metadata.xml b/dev-java/jikes/metadata.xml
new file mode 100644
index 000000000000..42250a2eee59
--- /dev/null
+++ b/dev-java/jikes/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">jikes</remote-id>
+ </upstream>
+</pkgmetadata>