summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-dotnet/pe-format
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-dotnet/pe-format')
-rw-r--r--dev-dotnet/pe-format/Manifest1
-rw-r--r--dev-dotnet/pe-format/files/pe-format.conf11
-rw-r--r--dev-dotnet/pe-format/files/pe-format.init-153
-rw-r--r--dev-dotnet/pe-format/metadata.xml17
-rw-r--r--dev-dotnet/pe-format/pe-format-2.1.2.ebuild38
-rw-r--r--dev-dotnet/pe-format/pe-format-2.9999.ebuild52
6 files changed, 172 insertions, 0 deletions
diff --git a/dev-dotnet/pe-format/Manifest b/dev-dotnet/pe-format/Manifest
new file mode 100644
index 000000000000..4ff3e0a052a4
--- /dev/null
+++ b/dev-dotnet/pe-format/Manifest
@@ -0,0 +1 @@
+DIST pe-format-2.1.2.tar.bz2 79023 SHA256 645430d6d4ace715094e452b5da70bbc759d0ae97ddb7393a995ab2a60b8cbf9 SHA512 c946384fdb95593f8b9390f77c7ccc2fc5ae2588412e37e868785523ca91f0d9d98e41928ec61c4cd1f47ba7d1b167cd7b6671f6662ac247d1d83a37b1c32b0f WHIRLPOOL 373717293ee8641193bfdef587ff7301a00c99737a57038cc849f2375138de1bc93d0ad634dd34829ce08255b2aedb2bf346ee6b0c7979bafb666b55f51f6e0d
diff --git a/dev-dotnet/pe-format/files/pe-format.conf b/dev-dotnet/pe-format/files/pe-format.conf
new file mode 100644
index 000000000000..b432728b0869
--- /dev/null
+++ b/dev-dotnet/pe-format/files/pe-format.conf
@@ -0,0 +1,11 @@
+# /etc/conf.d/pe-format
+
+# Define what to register with PE binaries so you can avoid running them with
+# "<.NET runtime> program.exe"
+# NOTE: In order to get this working you need to 'chmod +x' your program
+
+# CLR determines the executor for the PE binaries.
+# mono - Use the mono runtime engine 'mono'
+# ilrun - Use the DotGNU Portable .NET runtime engine 'ilrun'
+
+CLR="mono"
diff --git a/dev-dotnet/pe-format/files/pe-format.init-1 b/dev-dotnet/pe-format/files/pe-format.init-1
new file mode 100644
index 000000000000..18420db9c310
--- /dev/null
+++ b/dev-dotnet/pe-format/files/pe-format.init-1
@@ -0,0 +1,53 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ after procfs
+}
+
+start() {
+ ebegin "Registering PE binaries with ${CLR}"
+
+ if [[ ! -d /proc/sys/fs/binfmt_misc ]] ; then
+ eerror "You need support for \"misc binaries\" in your kernel!"
+ eend 1
+ fi
+
+ if [[ $(mount | grep -c binfmt_misc) -eq 0 ]] ; then
+ mount -t binfmt_misc binfmt_misc /proc/sys/fs/binfmt_misc &> /dev/null
+ local result=$?
+
+ if [[ $result -ne 0 ]] ; then
+ eend $result
+ fi
+ fi
+
+ case "${CLR}" in
+ mono)
+ echo ':PE:M::MZ::/usr/bin/mono:' > /proc/sys/fs/binfmt_misc/register
+ eend 0
+ ;;
+ ilrun)
+ echo ':PE:M::MZ::/usr/bin/ilrun:' > /proc/sys/fs/binfmt_misc/register
+ eend 0
+ ;;
+ *)
+ eerror 'Please enter a valid option in /etc/conf.d/pe-format'
+ eend 1
+ ;;
+ esac
+}
+
+stop() {
+ ebegin "Unregistering PE binaries"
+
+ if [[ -f /proc/sys/fs/binfmt_misc/PE ]] ; then
+ echo '-1' > /proc/sys/fs/binfmt_misc/PE
+ fi
+
+ eend $?
+}
+
+# vim: ts=4 :
diff --git a/dev-dotnet/pe-format/metadata.xml b/dev-dotnet/pe-format/metadata.xml
new file mode 100644
index 000000000000..c4626c89da13
--- /dev/null
+++ b/dev-dotnet/pe-format/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://bitbucket.org/mgorny/pe-format2/issues/</bugs-to>
+ <remote-id type="bitbucket">mgorny/pe-format2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-dotnet/pe-format/pe-format-2.1.2.ebuild b/dev-dotnet/pe-format/pe-format-2.1.2.ebuild
new file mode 100644
index 000000000000..311b50a45ca0
--- /dev/null
+++ b/dev-dotnet/pe-format/pe-format-2.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils fdo-mime systemd
+
+DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
+HOMEPAGE="https://bitbucket.org/mgorny/pe-format2/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}2/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/openrc-0.9.4"
+
+src_configure() {
+ local myeconfargs=(
+ "$(systemd_with_unitdir)"
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ keepdir /var/lib
+}
+
+pkg_postinst() {
+ ebegin "Calling pe-format2-setup to update handler setup"
+ pe-format2-setup
+ eend ${?}
+
+ fdo-mime_desktop_database_update
+}
diff --git a/dev-dotnet/pe-format/pe-format-2.9999.ebuild b/dev-dotnet/pe-format/pe-format-2.9999.ebuild
new file mode 100644
index 000000000000..a4a5667cefba
--- /dev/null
+++ b/dev-dotnet/pe-format/pe-format-2.9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}2.git"
+
+inherit git-r3
+#endif
+
+inherit autotools-utils fdo-mime systemd
+
+DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
+HOMEPAGE="https://bitbucket.org/mgorny/pe-format2/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}2/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/openrc-0.9.4"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+
+DEPEND="sys-devel/systemd-m4"
+#endif
+
+src_configure() {
+ local myeconfargs=(
+ "$(systemd_with_unitdir)"
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ keepdir /var/lib
+}
+
+pkg_postinst() {
+ ebegin "Calling pe-format2-setup to update handler setup"
+ pe-format2-setup
+ eend ${?}
+
+ fdo-mime_desktop_database_update
+}