summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-cpp/gccxml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-cpp/gccxml')
-rw-r--r--dev-cpp/gccxml/Manifest2
-rw-r--r--dev-cpp/gccxml/gccxml-0.9.0_pre20120309.ebuild28
-rw-r--r--dev-cpp/gccxml/gccxml-0.9.0_pre20131217.ebuild31
-rw-r--r--dev-cpp/gccxml/metadata.xml5
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-cpp/gccxml/Manifest b/dev-cpp/gccxml/Manifest
new file mode 100644
index 000000000000..7f6b701d402a
--- /dev/null
+++ b/dev-cpp/gccxml/Manifest
@@ -0,0 +1,2 @@
+DIST gccxml-0.9.0_pre20120309.tar.xz 10528336 SHA256 62ab146d790b2f97fc266e70c39495db97231781c1826811852ffdf8355cec35 SHA512 a5800519a184f0c3c13e424418fd67c59f84108deb20ed4f54620ed83c8624b7b163915684d99d9e13ac4d17726dd7dc8fe58c5fc6bd4290d00645af10dc5abd WHIRLPOOL d5cce97eb45b024fca5652dc966fc4b7c6f1de6a3c166b530a2a8e6ca2d9e46031b5c93a4c3458633b76a31cab22c923ea41ad94b535b1f5643de175bb319c44
+DIST gccxml-0.9.0_pre20131217.tar.xz 8134060 SHA256 2e0c934ff627cfa5d875d4560922101ccb567e904e15cf5197f41aa7063ffdbf SHA512 3fedb2fb7ec8025921b4d416230acd8f5dcc01858089e12837d702bd4bec0f841ec23dfd949ae7ff42b559e5da1832bfc32ee24c1a4b3ff6004e73d49a1a81cf WHIRLPOOL a9a1b801ff8736a7bfd5e8a0036ea05d0c76c6a0b389c05639baea4e8affb65fcaba15cf909a286cb29ef9e9545593799fedefb77b96e8a65b755a8edb30c099
diff --git a/dev-cpp/gccxml/gccxml-0.9.0_pre20120309.ebuild b/dev-cpp/gccxml/gccxml-0.9.0_pre20120309.ebuild
new file mode 100644
index 000000000000..ad2f5391b81a
--- /dev/null
+++ b/dev-cpp/gccxml/gccxml-0.9.0_pre20120309.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="XML output extension to GCC"
+HOMEPAGE="http://www.gccxml.org/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~mips ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+src_prepare() {
+ # patch below taken from Debian
+ sed -i \
+ -e 's/xatexit.c//' \
+ "${S}/GCC/libiberty/CMakeLists.txt" || die "sed failed"
+}
+
+src_configure() {
+ local mycmakeargs=( -DGCCXML_DOC_DIR:STRING=share/doc/${PF} )
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/gccxml/gccxml-0.9.0_pre20131217.ebuild b/dev-cpp/gccxml/gccxml-0.9.0_pre20131217.ebuild
new file mode 100644
index 000000000000..57fa75a1d98d
--- /dev/null
+++ b/dev-cpp/gccxml/gccxml-0.9.0_pre20131217.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="XML output extension to GCC"
+HOMEPAGE="http://www.gccxml.org/"
+SRC_URI="http://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+src_prepare() {
+ # patch below taken from Debian
+ sed -i \
+ -e 's/xatexit.c//' \
+ GCC/libiberty/CMakeLists.txt || die "sed failed"
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DGCCXML_DOC_DIR:STRING="share/doc/${PF}"
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/gccxml/metadata.xml b/dev-cpp/gccxml/metadata.xml
new file mode 100644
index 000000000000..bc97bb6ee207
--- /dev/null
+++ b/dev-cpp/gccxml/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cpp</herd>
+</pkgmetadata>