summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-15 22:56:38 +0000
committerSam James <sam@gentoo.org>2023-02-16 03:26:31 +0000
commit8218551e9fcebe957ee84e579daf26eb6a379576 (patch)
treeb6442cf55af0aa42dcb2b6dd508e90b9f869fd55 /dev-cpp/folly
parentdev-util/watchman: drop 2022.09.12.00, 2023.01.16.00 (diff)
downloadgentoo-8218551e9fcebe957ee84e579daf26eb6a379576.tar.gz
gentoo-8218551e9fcebe957ee84e579daf26eb6a379576.tar.bz2
gentoo-8218551e9fcebe957ee84e579daf26eb6a379576.zip
dev-cpp/folly: drop 2022.09.12.00, 2023.01.16.00-r1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/folly')
-rw-r--r--dev-cpp/folly/Manifest2
-rw-r--r--dev-cpp/folly/folly-2022.09.12.00.ebuild100
-rw-r--r--dev-cpp/folly/folly-2023.01.16.00-r1.ebuild104
3 files changed, 0 insertions, 206 deletions
diff --git a/dev-cpp/folly/Manifest b/dev-cpp/folly/Manifest
index 6f9dc306e7f9..b3d9597d58bd 100644
--- a/dev-cpp/folly/Manifest
+++ b/dev-cpp/folly/Manifest
@@ -1,4 +1,2 @@
DIST folly-v2022.08.29.00.tar.gz 3696645 BLAKE2B c1ff618be8b6a73bf0a1249212cf904ac472711086e54da73dd631ecf002761e30496e8631d6591f51e279b736ae9b3fe50959de6b1f86f01f9d6bc08fe675fc SHA512 1437a1314e26624715a0bb781049e19300eb3a67648287b319c55ce0dfbc867a09bd9d2f0cece6fc75fc62b21899aa94b464ae49c12687be7c94fdf0c7b95790
-DIST folly-v2022.09.12.00.tar.gz 3710760 BLAKE2B af59580ebee3229a6564c4b29e1d24bc405f4ae3b79751af315245c87472293f97c2d78348c92620d3196d1d41a7b55af9627cd42d23f74cbf6f00d129b3b77c SHA512 f9d0ca44f6f0c343d16e8ee5408808830b30155d42a257c48e627f9a82bb4a57568a7feeba01cf73704db68af1eee7424971540635d5dfe1728fc2ae73953940
-DIST folly-v2023.01.16.00.tar.gz 3774935 BLAKE2B e6c5925de0e571d83ac6db363a92f3d8c2fa7e911efc3db8f41b702dacd64aed5247313102ca12ca36a27a6fd8d8d5168ca8e98835f4000b425c10560a39e392 SHA512 941e09c90fab9e668d5f6b77f22caeff1da4347324c017ad64359748e18fc7c713d13f839d90a116164005041824c8a8d2039cfcc7687e23d9be8fa5acbd61ec
DIST folly-v2023.02.06.00.tar.gz 3790845 BLAKE2B b1c0eed7a2dccba3ccb5e25aa24cc0a6d628fbc3134bf0ed82a1e0e614825a3ae620d79a54e2bea398274afcb662bdfca48d7193f69db35f624ed6a2fa9bae99 SHA512 b9cd8132a702e88e4c9fefcce190d9fd403253c9b71dc22316f237922d99f9cd980ab81d50ddb48ae0e614a493b3d61865b03eee46d59805f83fce528f831646
diff --git a/dev-cpp/folly/folly-2022.09.12.00.ebuild b/dev-cpp/folly/folly-2022.09.12.00.ebuild
deleted file mode 100644
index fcc47d18f6a8..000000000000
--- a/dev-cpp/folly/folly-2022.09.12.00.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# These must be bumped together:
-# dev-cpp/edencommon
-# dev-cpp/folly
-# dev-util/watchman
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="An open-source C++ library developed and used at Facebook"
-HOMEPAGE="https://github.com/facebook/folly"
-SRC_URI="https://github.com/facebook/folly/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
-S="${WORKDIR}"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="llvm-libunwind test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="app-arch/bzip2
- app-arch/lz4:=
- app-arch/snappy:=
- app-arch/xz-utils
- app-arch/zstd:=
- dev-cpp/gflags:=
- dev-cpp/glog:=[gflags]
- dev-libs/boost:=[context]
- dev-libs/double-conversion:=
- dev-libs/libaio
- dev-libs/libevent:=
- dev-libs/libfmt:=
- dev-libs/libsodium:=
- dev-libs/openssl:=
- >=sys-libs/liburing-2.2:=
- sys-libs/zlib
- llvm-libunwind? ( sys-libs/llvm-libunwind:= )
- !llvm-libunwind? ( sys-libs/libunwind:= )"
-# libiberty is linked statically
-DEPEND="${RDEPEND}
- sys-libs/binutils-libs
- test? ( dev-cpp/gtest )"
-BDEPEND="test? ( sys-devel/clang )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2022.07.04.00-musl-fix.patch
-)
-
-pkg_setup() {
- [[ ${BUILD_TYPE} == binary ]] && return
-
- if use test && ! tc-is-clang ; then
- # Always build w/ Clang for now to avoid gcc ICE
- # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=106230
- #if [[ $(gcc-major-version) -eq 12 ]] ; then
- # return
- #fi
-
- ## Only older GCC 11 is broken
- #if [[ $(gcc-major-version) -eq 11 && $(gcc-minor-version) -ge 3 && $(gcc-micro-version) -ge 1 ]] ; then
- # return
- #fi
-
- ewarn "Forcing build with Clang due to GCC bug (because tests are enabled)"
- #ewarn "(https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104008)"
-
- export CC=${CHOST}-clang
- export CXX=${CHOST}-clang++
- fi
-}
-
-src_configure() {
- # Fragile when changing compilers
- export CCACHE_DISABLE=1
-
- # TODO: liburing could in theory be optional but fails to link
- local mycmakeargs=(
- -DLIB_INSTALL_DIR="$(get_libdir)"
-
- -DBUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
-
-src_test() {
- local myctestargs=(
- # - timeseries_histogram_test.TimeseriesHistogram.Percentile|HHWheelTimerTest
- # Long-standing known test failure
- # TODO: report upstream
- # - HHWheelTimerTest.HHWheelTimerTest.CancelTimeout
- # Timeouts are fragile
- -E "(timeseries_histogram_test.TimeseriesHistogram.Percentile|HHWheelTimerTest.HHWheelTimerTest.CancelTimeout)"
- )
-
- cmake_src_test
-}
diff --git a/dev-cpp/folly/folly-2023.01.16.00-r1.ebuild b/dev-cpp/folly/folly-2023.01.16.00-r1.ebuild
deleted file mode 100644
index 6c6ee5cfd970..000000000000
--- a/dev-cpp/folly/folly-2023.01.16.00-r1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# These must be bumped together:
-# dev-cpp/edencommon
-# dev-cpp/folly
-# dev-util/watchman
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="An open-source C++ library developed and used at Facebook"
-HOMEPAGE="https://github.com/facebook/folly"
-SRC_URI="https://github.com/facebook/folly/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
-S="${WORKDIR}"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="llvm-libunwind test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="app-arch/bzip2
- app-arch/lz4:=
- app-arch/snappy:=
- app-arch/xz-utils
- app-arch/zstd:=
- dev-cpp/gflags:=
- dev-cpp/glog:=[gflags]
- dev-libs/boost:=[context]
- dev-libs/double-conversion:=
- dev-libs/libaio
- dev-libs/libevent:=
- dev-libs/libfmt:=
- dev-libs/libsodium:=
- dev-libs/openssl:=
- >=sys-libs/liburing-2.3:=
- sys-libs/zlib
- llvm-libunwind? ( sys-libs/llvm-libunwind:= )
- !llvm-libunwind? ( sys-libs/libunwind:= )"
-# libiberty is linked statically
-DEPEND="${RDEPEND}
- sys-libs/binutils-libs
- test? ( dev-cpp/gtest )"
-BDEPEND="test? ( sys-devel/clang )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2022.07.04.00-musl-fix.patch
- "${FILESDIR}"/${PN}-2023.01.16.00-gcc13.patch
- "${FILESDIR}"/${P}-liburing.patch
-)
-
-pkg_setup() {
- [[ ${BUILD_TYPE} == binary ]] && return
-
- if use test && ! tc-is-clang ; then
- # Always build w/ Clang for now to avoid gcc ICE
- # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=106230
- #if [[ $(gcc-major-version) -eq 12 ]] ; then
- # return
- #fi
-
- ## Only older GCC 11 is broken
- #if [[ $(gcc-major-version) -eq 11 && $(gcc-minor-version) -ge 3 && $(gcc-micro-version) -ge 1 ]] ; then
- # return
- #fi
-
- ewarn "Forcing build with Clang due to GCC bug (because tests are enabled)"
- #ewarn "(https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104008)"
-
- export CC=${CHOST}-clang
- export CXX=${CHOST}-clang++
- fi
-}
-
-src_configure() {
- # Fragile when changing compilers
- export CCACHE_DISABLE=1
-
- # TODO: liburing could in theory be optional but fails to link
- local mycmakeargs=(
- -DLIB_INSTALL_DIR="$(get_libdir)"
-
- -DBUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
-
-src_test() {
- local myctestargs=(
- # - timeseries_histogram_test.TimeseriesHistogram.Percentile|HHWheelTimerTest
- # Long-standing known test failure
- # TODO: report upstream
- # - HHWheelTimerTest.HHWheelTimerTest.CancelTimeout
- # Timeouts are fragile
- # - concurrent_hash_map_test.*
- # TODO: All SIGSEGV, report upstream!
- -E "(timeseries_histogram_test.TimeseriesHistogram.Percentile|HHWheelTimerTest.HHWheelTimerTest.CancelTimeout|concurrent_hash_map_test.*)"
- )
-
- cmake_src_test
-}