summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/gundo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/gundo')
-rw-r--r--app-vim/gundo/Manifest3
-rw-r--r--app-vim/gundo/gundo-2.2.2.ebuild30
-rw-r--r--app-vim/gundo/gundo-2.4.0.ebuild23
-rw-r--r--app-vim/gundo/gundo-2.5.0.ebuild25
-rw-r--r--app-vim/gundo/metadata.xml8
5 files changed, 89 insertions, 0 deletions
diff --git a/app-vim/gundo/Manifest b/app-vim/gundo/Manifest
new file mode 100644
index 000000000000..0676722fe6ff
--- /dev/null
+++ b/app-vim/gundo/Manifest
@@ -0,0 +1,3 @@
+DIST gundo-2.2.2.tar.gz 15207 SHA256 218f410908d3e10fbbb5083b0b2362fd8997147b784a28b8276028b953d45805 SHA512 4fa2cd3570aa5621140bd5ec4b513adfff8d2e3173c3d684daf8b3d8f75882fe5d10afa61c2e21e2c367a013b347f92b6504a958684b9161a34f523fe57fa805 WHIRLPOOL e8b5533f71e9809839d402033bbf1b0e976e372c722c8a548435adb51f4bc8451aa02bafc5e91d636d25653887d649dccad07edb1164499c1201c70fd3064242
+DIST gundo-2.4.0.tar.gz 152544 SHA256 4417fd2ef261a91f56b26cf0cb3be38a047e288bae8e7bd0d4d4d8f8d6455bfe SHA512 17b1b9fa9b73592af92d7b7729872bdd2b440b8af516f026cfd6fea53e82720821b4a0d2639e351c16565591b36a7adb68a3335c4fcb34015319b89331fde29d WHIRLPOOL b5be58c92e7d1c7ad7342555f7ada561ae000922f9a2c1f956d98a03c5311a52b477491977b9fa01d241e831e1da791f10fc624fe99f182b8c1c20ba7f2d814e
+DIST gundo-2.5.0.tar.gz 152724 SHA256 d7d0c0633937d8cde5d42b6c9634f3ee9b879252b9615f45b49d002320c3b24a SHA512 85687e0baa00d6c603dcabc9ffa5fef3c49437d816a7e637fa9f48719726bc4d4f45417998d9a080d2796c1e3b1bf76318628f7733a9985fd8f46e053aec42db WHIRLPOOL c1086ec377fe8fc204ee1c66feeb6a45063f51094715f4e0e1c9c0fbf8882721e6a0ccfa759f27256602fe2f3d8ef26b505aed19c431cb98e4be82c35d1bc60f
diff --git a/app-vim/gundo/gundo-2.2.2.ebuild b/app-vim/gundo/gundo-2.2.2.ebuild
new file mode 100644
index 000000000000..054001b945ff
--- /dev/null
+++ b/app-vim/gundo/gundo-2.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+VIM_PLUGIN_VIM_VERSION="7.3"
+
+inherit vim-plugin
+
+MY_PN="Gundo"
+DESCRIPTION="vim plugin: visualize your Vim undo tree"
+HOMEPAGE="http://sjl.bitbucket.org/gundo.vim/"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ >=dev-lang/python-2.4"
+
+VIM_PLUGIN_HELPFILES="gundo.txt"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ rm -f README*
+}
diff --git a/app-vim/gundo/gundo-2.4.0.ebuild b/app-vim/gundo/gundo-2.4.0.ebuild
new file mode 100644
index 000000000000..4a18370e9828
--- /dev/null
+++ b/app-vim/gundo/gundo-2.4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit vim-plugin vcs-snapshot
+
+DESCRIPTION="vim plugin: visualize your Vim undo tree"
+HOMEPAGE="http://sjl.bitbucket.org/gundo.vim/"
+SRC_URI="https://github.com/sjl/gundo.vim/tarball/v${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ >=dev-lang/python-2.4"
+
+VIM_PLUGIN_HELPFILES="gundo.txt"
+
+src_prepare() {
+ rm -r .gitignore .hg* package.sh README* site tests || die
+}
diff --git a/app-vim/gundo/gundo-2.5.0.ebuild b/app-vim/gundo/gundo-2.5.0.ebuild
new file mode 100644
index 000000000000..e7bcfdfe7c0d
--- /dev/null
+++ b/app-vim/gundo/gundo-2.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: visualize your Vim undo tree"
+HOMEPAGE="http://sjl.bitbucket.org/gundo.vim/"
+SRC_URI="https://github.com/sjl/gundo.vim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+
+RDEPEND="|| ( app-editors/vim[${PYTHON_USEDEP}] app-editors/gvim[${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}"
+
+S=${WORKDIR}/${PN}.vim-${PV}
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ rm -r .gitignore .hg* package.sh README* site tests || die
+}
diff --git a/app-vim/gundo/metadata.xml b/app-vim/gundo/metadata.xml
new file mode 100644
index 000000000000..77a343a48394
--- /dev/null
+++ b/app-vim/gundo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="github">sjl/gundo.vim</remote-id>
+ </upstream>
+</pkgmetadata>