summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgryf <gryf73@gmail.com>2019-12-15 10:01:17 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-12-15 10:05:58 +0200
commit43db9092c5257ce252ff8fcbce7a1a0c112fbe58 (patch)
tree53dec723b56e2d6bc6302c1e2b042cba0fcf9fb1 /app-pda
parentapp-misc/cargo-license: clean old 0.2.0 (diff)
downloadgentoo-43db9092c5257ce252ff8fcbce7a1a0c112fbe58.tar.gz
gentoo-43db9092c5257ce252ff8fcbce7a1a0c112fbe58.tar.bz2
gentoo-43db9092c5257ce252ff8fcbce7a1a0c112fbe58.zip
app-pda/jpilot: Fix paths with plugins on newest profile.
Closes: https://bugs.gentoo.org/688098 Signed-off-by: Roman Dobosz <gryf73@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/jpilot/jpilot-1.8.2-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-pda/jpilot/jpilot-1.8.2-r1.ebuild b/app-pda/jpilot/jpilot-1.8.2-r1.ebuild
new file mode 100644
index 000000000000..7938cdb42bc3
--- /dev/null
+++ b/app-pda/jpilot/jpilot-1.8.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Desktop Organizer Software for the Palm Pilot"
+HOMEPAGE="http://www.jpilot.org/"
+SRC_URI="http://jpilot.org/tarballs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 x86"
+IUSE="nls"
+
+RDEPEND="
+ app-pda/pilot-link
+ dev-libs/libgcrypt:0=
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.2-qa-desktop-file.patch
+ "${FILESDIR}"/${PN}-1.8.2-fix-paths.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e 's|_UNQUOTED(ABILIB, "lib"|_UNQUOTED(ABILIB, "'$(get_libdir)'"|' configure.in || die
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+ docompress -x /usr/share/doc/${PF}/icons
+
+ # .la files for plugins are useless
+ find "${D}" -name '*.la' -delete || die
+}