summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai-Chun Ning <kaichun.ning@gmail.com>2023-03-02 21:00:43 +0000
committerViorel Munteanu <ceamac@gentoo.org>2023-03-22 10:08:04 +0200
commit6d331cc2fe252cf706f494287aafb6df4c1e9b95 (patch)
treee3ab0de092e6ee237176f0050bb9936295fde21a /app-office
parentdev-ml/findlib: cleanup check_stublibs (diff)
downloadgentoo-6d331cc2fe252cf706f494287aafb6df4c1e9b95.tar.gz
gentoo-6d331cc2fe252cf706f494287aafb6df4c1e9b95.tar.bz2
gentoo-6d331cc2fe252cf706f494287aafb6df4c1e9b95.zip
app-office/calcurse: add 4.8.0
Closes: https://bugs.gentoo.org/896606 Signed-off-by: Kai-Chun Ning <kaichun.ning@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29903 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/calcurse/Manifest1
-rw-r--r--app-office/calcurse/calcurse-4.8.0.ebuild51
-rw-r--r--app-office/calcurse/metadata.xml26
3 files changed, 70 insertions, 8 deletions
diff --git a/app-office/calcurse/Manifest b/app-office/calcurse/Manifest
index 2802d1e62fff..57c411b05906 100644
--- a/app-office/calcurse/Manifest
+++ b/app-office/calcurse/Manifest
@@ -1 +1,2 @@
DIST calcurse-4.7.1.tar.gz 701563 BLAKE2B 438741b9e0f61438d235fa60d13816d83c19f7d1b612619fe20a78812e77657b003ad0b9416bcc766f0e38e7868b3543972ed65eee43d8f9d6b1d80ba1872091 SHA512 8b5574d2909128c745b2d6367b517c5fb04a1c451e666dc9ee0652b3793b519576af5700d4fd073de0ccd5e5dced6b69c45dbfaf98b35a99784093208512b68e
+DIST calcurse-4.8.0.tar.gz 716234 BLAKE2B 3fc703626d5e17b78ff42c0ef4f554585efd8223c2bd9d8c2f7add681602dc585cf066ed7c55a040b2585ad07513b26a5297b3b41f4c94a043f61ad2ad9094c2 SHA512 ea156c4320abf97fdb5abc29ff1f9bc659a3cab0e571295ed04b42dd742c4c45a7d5958dc2d386fc0ee7bd733969a6275405d5cf10cd645c75cb97b6b9e571d6
diff --git a/app-office/calcurse/calcurse-4.8.0.ebuild b/app-office/calcurse/calcurse-4.8.0.ebuild
new file mode 100644
index 000000000000..1b3a331cd35c
--- /dev/null
+++ b/app-office/calcurse/calcurse-4.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit python-single-r1
+
+DESCRIPTION="A text-based calendar and scheduling application"
+HOMEPAGE="https://calcurse.org/"
+SRC_URI="https://calcurse.org/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="caldav doc"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ ${PYTHON_DEPS}
+ caldav? (
+ $(python_gen_cond_dep '
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable doc docs)
+ --without-asciidoc # do not use AsciiDoc to regenerate docs
+ )
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+ python_fix_shebang contrib/caldav/calcurse-caldav
+}
+
+src_install() {
+ docompress -x /usr/share/doc # decompress text files
+ default
+}
diff --git a/app-office/calcurse/metadata.xml b/app-office/calcurse/metadata.xml
index 007b546f8cc5..ecd9a39d3c64 100644
--- a/app-office/calcurse/metadata.xml
+++ b/app-office/calcurse/metadata.xml
@@ -1,12 +1,22 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription>
- Calcurse is a text-based personal organizer which helps keeping track of
- events and everyday tasks. It contains a calendar, a 'todo' list, and
- puts your appointments in order. The user interface is configurable, and
- one can choose between different color schemes and layouts. All of the
- commands are documented within an online help system.
- </longdescription>
+ <longdescription>
+ Calcurse is a text-based personal organizer which helps keeping track of
+ events and everyday tasks. It contains a calendar, a 'todo' list, and
+ puts your appointments in order. The user interface is configurable, and
+ one can choose between different color schemes and layouts. All of the
+ commands are documented within an online help system.
+ </longdescription>
+ <maintainer type="person" proxied="yes">
+ <email>kaichun.ning@gmail.com</email>
+ <name>Kai-Chun Ning</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="caldav">Support CalDAV</flag>
+ </use>
</pkgmetadata>