summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-03-06 07:40:30 +0100
committerYixun Lan <dlan@gentoo.org>2020-03-06 22:33:09 +0000
commit4e1a0667c9be4b76c4eef62be717be4ba288a147 (patch)
treea98c5cd885e10b046ab43120e7638d1991406ab5 /app-emulation
parentnet-libs/quiche: Remove criterion (diff)
downloadgentoo-4e1a0667c9be4b76c4eef62be717be4ba288a147.tar.gz
gentoo-4e1a0667c9be4b76c4eef62be717be4ba288a147.tar.bz2
gentoo-4e1a0667c9be4b76c4eef62be717be4ba288a147.zip
app-emulation/xen: warn about credit2 scheduler instability
Bug: https://bugs.gentoo.org/710140 Closes: https://github.com/gentoo/gentoo/pull/14842 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen/xen-4.12.2.ebuild9
-rw-r--r--app-emulation/xen/xen-4.13.0-r1.ebuild9
2 files changed, 18 insertions, 0 deletions
diff --git a/app-emulation/xen/xen-4.12.2.ebuild b/app-emulation/xen/xen-4.12.2.ebuild
index ec19a8729db3..078c4ede6785 100644
--- a/app-emulation/xen/xen-4.12.2.ebuild
+++ b/app-emulation/xen/xen-4.12.2.ebuild
@@ -153,4 +153,13 @@ pkg_postinst() {
elog "You can optionally block the installation of /boot/xen-syms by an entry"
elog "in folder /etc/portage/env using the portage's feature INSTALL_MASK"
elog "e.g. echo ${msg} > /etc/portage/env/xen.conf"
+
+ ewarn
+ ewarn "Xen 4.12+ changed the default scheduler to credit2 which can cause"
+ ewarn "domU lockups on multi-cpu systems. The legacy credit scheduler seems"
+ ewarn "to work fine."
+ ewarn
+ ewarn "Add sched=credit to xen command line options to use the legacy scheduler."
+ ewarn
+ ewarn "https://wiki.gentoo.org/wiki/Xen#Xen_domU_hanging_with_Xen_4.12.2B"
}
diff --git a/app-emulation/xen/xen-4.13.0-r1.ebuild b/app-emulation/xen/xen-4.13.0-r1.ebuild
index 2c03982f6608..7da3187cee25 100644
--- a/app-emulation/xen/xen-4.13.0-r1.ebuild
+++ b/app-emulation/xen/xen-4.13.0-r1.ebuild
@@ -153,4 +153,13 @@ pkg_postinst() {
elog "You can optionally block the installation of /boot/xen-syms by an entry"
elog "in folder /etc/portage/env using the portage's feature INSTALL_MASK"
elog "e.g. echo ${msg} > /etc/portage/env/xen.conf"
+
+ ewarn
+ ewarn "Xen 4.12+ changed the default scheduler to credit2 which can cause"
+ ewarn "domU lockups on multi-cpu systems. The legacy credit scheduler seems"
+ ewarn "to work fine."
+ ewarn
+ ewarn "Add sched=credit to xen command line options to use the legacy scheduler."
+ ewarn
+ ewarn "https://wiki.gentoo.org/wiki/Xen#Xen_domU_hanging_with_Xen_4.12.2B"
}