summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-06-23 14:18:34 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-06-23 14:44:43 -0400
commit8acb1d27a6ddbdadb86d17fe18492ec9ab1a941e (patch)
treeadc9d90d98ea3aafb9cd9a2d627b39b1850d9089 /app-emulation/vkd3d
parentapp-containers/distrobox: drop old 1.5.0.1 (diff)
downloadgentoo-8acb1d27a6ddbdadb86d17fe18492ec9ab1a941e.tar.gz
gentoo-8acb1d27a6ddbdadb86d17fe18492ec9ab1a941e.tar.bz2
gentoo-8acb1d27a6ddbdadb86d17fe18492ec9ab1a941e.zip
app-emulation/vkd3d: add 1.8
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/vkd3d')
-rw-r--r--app-emulation/vkd3d/Manifest1
-rw-r--r--app-emulation/vkd3d/vkd3d-1.8.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-emulation/vkd3d/Manifest b/app-emulation/vkd3d/Manifest
index f42c15abcfb0..1a51bb258a8d 100644
--- a/app-emulation/vkd3d/Manifest
+++ b/app-emulation/vkd3d/Manifest
@@ -1 +1,2 @@
DIST vkd3d-1.7.1.tar.xz 806772 BLAKE2B f83fd405dd2fedb2bc38bf64fd5e401fab1b9d5364b812eb34bc45cdeef684786cd59abe304ce71c722b8fe7a729bef18a90b1cb86f2522e45fa1f4d2d0340bb SHA512 59958d3ca6a6485173cc43d701dba4e82eca1eee895128520b5eb0c392fc2911cade37d945ba52a8f50a2639fa5d8d487609c5f3f88ae76e6d914a448ac179b6
+DIST vkd3d-1.8.tar.xz 829648 BLAKE2B 0e7bb53e3eb9003ea76ee523dfa317b6ab95fd1c2decb453d650f0cf046d5b802a32e40c4e6f6464748903143ef9352e70fdf8ca7fa8e9b9909e0f15235d2b01 SHA512 43d65bf4aa60750e08653226197f40c97bc88d56dc5513b70182b5fe289ab56a225682c96400776cd625ad5a8f76644bf4b46bd3ed54aa8496f538f6854d680a
diff --git a/app-emulation/vkd3d/vkd3d-1.8.ebuild b/app-emulation/vkd3d/vkd3d-1.8.ebuild
new file mode 100644
index 000000000000..cea4a98c8e5e
--- /dev/null
+++ b/app-emulation/vkd3d/vkd3d-1.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="D3D12 to Vulkan translation library"
+HOMEPAGE="https://gitlab.winehq.org/wine/vkd3d/"
+SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses spirv-tools"
+RESTRICT="test" #838655
+
+RDEPEND="
+ media-libs/vulkan-loader[${MULTILIB_USEDEP}]
+ ncurses? ( sys-libs/ncurses:= )
+ spirv-tools? ( dev-util/spirv-tools[${MULTILIB_USEDEP}] )"
+DEPEND="
+ ${RDEPEND}
+ dev-util/spirv-headers
+ dev-util/vulkan-headers"
+BDEPEND="
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig"
+
+multilib_src_configure() {
+ local conf=(
+ $(multilib_native_use_with ncurses)
+ $(use_with spirv-tools)
+ --disable-doxygen-pdf
+ --without-xcb
+ )
+
+ ECONF_SOURCE=${S} econf "${conf[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name '*.la' -delete || die
+}