summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-05-16 23:46:00 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-05-17 00:15:53 -0400
commit3f6a6d4b239cef61e4a839a377e2ce67bef5471f (patch)
treee6b49741ca1a5afccdc4985b0d5e0b217429182d /app-emulation/dxvk
parentdev-go/coveraggregator: treeclean (diff)
downloadgentoo-3f6a6d4b239cef61e4a839a377e2ce67bef5471f.tar.gz
gentoo-3f6a6d4b239cef61e4a839a377e2ce67bef5471f.tar.bz2
gentoo-3f6a6d4b239cef61e4a839a377e2ce67bef5471f.zip
app-emulation/dxvk: give note about overlay differences
Just a courtesy until this version settles in, been in overlays for a long time and switching back & forth can give a poor experience. Similar applies to vkd3d-proton but it's less known and overlays only had live ebuilds. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/dxvk')
-rw-r--r--app-emulation/dxvk/dxvk-1.10.1.ebuild14
-rw-r--r--app-emulation/dxvk/dxvk-9999.ebuild14
2 files changed, 28 insertions, 0 deletions
diff --git a/app-emulation/dxvk/dxvk-1.10.1.ebuild b/app-emulation/dxvk/dxvk-1.10.1.ebuild
index 7d293dd8f8ea..d0bfdb15b8ca 100644
--- a/app-emulation/dxvk/dxvk-1.10.1.ebuild
+++ b/app-emulation/dxvk/dxvk-1.10.1.ebuild
@@ -102,6 +102,10 @@ multilib_src_install_all() {
find "${ED}" -type f -name '*.a' -delete || die
}
+pkg_preinst() {
+ [[ -e /usr/$(get_libdir)/dxvk/d3d11.dll ]] && DXVK_HAD_OVERLAY=
+}
+
pkg_postinst() {
if [[ ! ${REPLACING_VERSIONS} ]]; then
elog "To enable ${PN} on a wine prefix, you can run the following command:"
@@ -109,6 +113,16 @@ pkg_postinst() {
elog " WINEPREFIX=/path/to/prefix setup_dxvk.sh install --symlink"
elog
elog "See ${EROOT}/usr/share/doc/${PF}/README.md* for details."
+ elif [[ -v DXVK_HAD_OVERLAY ]]; then
+ # temporary warning until this version is more widely used
+ elog "Gentoo's main repo ebuild for ${PN} uses different paths than most overlays."
+ elog "If you were using symbolic links in wine prefixes it may be necessary to"
+ elog "refresh them by re-running the command:"
+ elog
+ elog " WINEPREFIX=/path/to/prefix setup_dxvk.sh install --symlink"
+ elog
+ elog "Also, if you were using /etc/${PN}.conf, ${PN} is no longer patched to load"
+ elog "it. See ${EROOT}/usr/share/doc/${PF}/README.md* for handling configs."
fi
# don't try to keep wine-*[vulkan] in RDEPEND, but still give a warning
diff --git a/app-emulation/dxvk/dxvk-9999.ebuild b/app-emulation/dxvk/dxvk-9999.ebuild
index 7d293dd8f8ea..d0bfdb15b8ca 100644
--- a/app-emulation/dxvk/dxvk-9999.ebuild
+++ b/app-emulation/dxvk/dxvk-9999.ebuild
@@ -102,6 +102,10 @@ multilib_src_install_all() {
find "${ED}" -type f -name '*.a' -delete || die
}
+pkg_preinst() {
+ [[ -e /usr/$(get_libdir)/dxvk/d3d11.dll ]] && DXVK_HAD_OVERLAY=
+}
+
pkg_postinst() {
if [[ ! ${REPLACING_VERSIONS} ]]; then
elog "To enable ${PN} on a wine prefix, you can run the following command:"
@@ -109,6 +113,16 @@ pkg_postinst() {
elog " WINEPREFIX=/path/to/prefix setup_dxvk.sh install --symlink"
elog
elog "See ${EROOT}/usr/share/doc/${PF}/README.md* for details."
+ elif [[ -v DXVK_HAD_OVERLAY ]]; then
+ # temporary warning until this version is more widely used
+ elog "Gentoo's main repo ebuild for ${PN} uses different paths than most overlays."
+ elog "If you were using symbolic links in wine prefixes it may be necessary to"
+ elog "refresh them by re-running the command:"
+ elog
+ elog " WINEPREFIX=/path/to/prefix setup_dxvk.sh install --symlink"
+ elog
+ elog "Also, if you were using /etc/${PN}.conf, ${PN} is no longer patched to load"
+ elog "it. See ${EROOT}/usr/share/doc/${PF}/README.md* for handling configs."
fi
# don't try to keep wine-*[vulkan] in RDEPEND, but still give a warning