summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-12-29 00:54:24 -0800
committerZac Medico <zmedico@gentoo.org>2020-12-29 00:59:33 -0800
commit7f6529a2533ed410816d79c4e514de5eddc2f449 (patch)
treeb3a115c7d1bd79c89bd2e81671bafb21354eae02 /app-emulation/conmon/conmon-2.0.22.ebuild
parentapp-emulation/conmon: Add dev-go/go-md2man to DEPEND (diff)
downloadgentoo-7f6529a2533ed410816d79c4e514de5eddc2f449.tar.gz
gentoo-7f6529a2533ed410816d79c4e514de5eddc2f449.tar.bz2
gentoo-7f6529a2533ed410816d79c4e514de5eddc2f449.zip
app-emulation/conmon: use CC variable and system go-md2man
Closes: https://bugs.gentoo.org/762376 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/conmon/conmon-2.0.22.ebuild')
-rw-r--r--app-emulation/conmon/conmon-2.0.22.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/app-emulation/conmon/conmon-2.0.22.ebuild b/app-emulation/conmon/conmon-2.0.22.ebuild
index e8b2c72ef579..22d66f80a279 100644
--- a/app-emulation/conmon/conmon-2.0.22.ebuild
+++ b/app-emulation/conmon/conmon-2.0.22.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit toolchain-funcs
+
EGIT_COMMIT="9c34a8663b85e479e0c083801e89a2b2835228ed"
DESCRIPTION="An OCI container runtime monitor"
HOMEPAGE="https://github.com/containers/conmon"
@@ -29,9 +31,12 @@ src_prepare() {
-e 's| $(PKG_CONFIG) --exists libsystemd | false |' \
-i Makefile || die
fi
+ sed -e 's|make -C tools|$(MAKE) -C tools|' -i Makefile || die
+ sed -e 's|^GOMD2MAN = .*|GOMD2MAN = go-md2man|' -i docs/Makefile || die
}
src_compile() {
+ tc-export CC
emake GIT_COMMIT="${EGIT_COMMIT}" \
all
}