summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2016-06-09 22:34:27 +0200
committerUlrich Müller <ulm@gentoo.org>2016-06-09 22:34:27 +0200
commit40c0c3428d45bf9bd1704a8e7cb8b3f3ef7606e0 (patch)
treea291011f547bd917b67b0e5a8c47445947989288 /app-emacs/ess/ess-16.04.ebuild
parentsci-mathematics/gfan: gcc-6.1 compat and EAPI=6 (diff)
downloadgentoo-40c0c3428d45bf9bd1704a8e7cb8b3f3ef7606e0.tar.gz
gentoo-40c0c3428d45bf9bd1704a8e7cb8b3f3ef7606e0.tar.bz2
gentoo-40c0c3428d45bf9bd1704a8e7cb8b3f3ef7606e0.zip
app-emacs/ess: Version bump.
Bug: 585470 Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'app-emacs/ess/ess-16.04.ebuild')
-rw-r--r--app-emacs/ess/ess-16.04.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-emacs/ess/ess-16.04.ebuild b/app-emacs/ess/ess-16.04.ebuild
new file mode 100644
index 000000000000..b91b788f9043
--- /dev/null
+++ b/app-emacs/ess/ess-16.04.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Emacs Speaks Statistics"
+HOMEPAGE="http://ess.r-project.org/"
+SRC_URI="http://ess.r-project.org/downloads/ess/${P}.tgz"
+
+LICENSE="GPL-2+ GPL-3+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND="app-text/texi2html
+ virtual/latex-base"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" \
+ INFODIR="${ED}/usr/share/info" \
+ LISPDIR="${ED}${SITELISP}/ess" \
+ DOCDIR="${ED}/usr/share/doc/${PF}" \
+ install
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ # Most documentation is installed by the package's build system.
+ rm -f "${ED}${SITELISP}/${PN}/ChangeLog"
+ dodoc ChangeLog *NEWS doc/{TODO,ess-intro.pdf}
+ newdoc doc/ChangeLog ChangeLog-doc
+ newdoc lisp/ChangeLog ChangeLog-lisp
+
+ DOC_CONTENTS="Please see /usr/share/doc/${PF} for the complete
+ documentation. Usage hints are in ${SITELISP}/${PN}/ess-site.el ."
+ readme.gentoo_create_doc
+}