summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-14 21:17:32 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 21:17:32 +0100
commit37fb92017312fe73f1e27501a8eecd1d5e0ffcde (patch)
treed710dbb8091eb30dd2cde0645f8959571f989140 /app-crypt/ima-evm-utils
parentapp-crypt/dieharder: disable static libs (diff)
downloadgentoo-37fb92017312fe73f1e27501a8eecd1d5e0ffcde.tar.gz
gentoo-37fb92017312fe73f1e27501a8eecd1d5e0ffcde.tar.bz2
gentoo-37fb92017312fe73f1e27501a8eecd1d5e0ffcde.zip
app-crypt/ima-evm-utils: disable static libs
Closes: https://bugs.gentoo.org/726436 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt/ima-evm-utils')
-rw-r--r--app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild11
-rw-r--r--app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild11
2 files changed, 18 insertions, 4 deletions
diff --git a/app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild b/app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild
index 93152d948962..4d2555451e10 100644
--- a/app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild
+++ b/app-crypt/ima-evm-utils/ima-evm-utils-1.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -35,5 +35,12 @@ src_prepare() {
}
src_configure() {
- econf $(use_enable debug)
+ econf \
+ $(use_enable debug) \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild b/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild
index 1a92d1287ad1..d967038aff71 100644
--- a/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild
+++ b/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,5 +30,12 @@ src_prepare() {
}
src_configure() {
- econf $(use_enable debug)
+ econf \
+ $(use_enable debug) \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
}