summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/chntpw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/chntpw')
-rw-r--r--app-crypt/chntpw/Manifest2
-rw-r--r--app-crypt/chntpw/chntpw-110511.ebuild47
-rw-r--r--app-crypt/chntpw/chntpw-140201.ebuild48
-rw-r--r--app-crypt/chntpw/metadata.xml5
4 files changed, 102 insertions, 0 deletions
diff --git a/app-crypt/chntpw/Manifest b/app-crypt/chntpw/Manifest
new file mode 100644
index 000000000000..477187210275
--- /dev/null
+++ b/app-crypt/chntpw/Manifest
@@ -0,0 +1,2 @@
+DIST chntpw-source-110511.zip 758936 SHA256 593514ca8601adb4091d951499b916dfdac2bd34b325d307237fa52ca572b5b7 SHA512 2a0b3638df40481d0650a5fb524b37896db253db83eb8e12836a3f59f12df59bea89ae92710e28bd08dc01f6fa806789be118397fd097732f7132571d3057d56 WHIRLPOOL d3a9e61109f8cc2721ee734cfd6f5da914fc6397e762de3a4e9192b568c24c9c7088d77630dfb93e709f043a54244c5344a2b6fbfdc1bd36881ee4299b805812
+DIST chntpw-source-140201.zip 1404098 SHA256 96e20905443e24cba2f21e51162df71dd993a1c02bfa12b1be2d0801a4ee2ccc SHA512 a26d747f6e077d1bb3e9b8077781f8c37dd978e07b7426495862f15c9004572b706c34736fc4d1ed8856b1a43335d726b4d87c688f7f9a11fd6cc3a74d71a7fa WHIRLPOOL 87284c123d2ae1965d069d4d97cda23ce757305b3521f84089e43a9f1fa8aaa48f8fbad5bba19b3a439cfb16d270e0f77f528664fdba895c65c100492eb9e42a
diff --git a/app-crypt/chntpw/chntpw-110511.ebuild b/app-crypt/chntpw/chntpw-110511.ebuild
new file mode 100644
index 000000000000..80037eb2b7d1
--- /dev/null
+++ b/app-crypt/chntpw/chntpw-110511.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="Offline Windows NT Password & Registry Editor"
+HOMEPAGE="http://pogostick.net/~pnh/ntpasswd/"
+SRC_URI="http://pogostick.net/~pnh/ntpasswd/${PN}-source-${PV}.zip"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ static? ( dev-libs/openssl[static-libs] )"
+
+src_prepare() {
+ sed -i -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' Makefile || die
+
+ if ! use static ; then
+ sed -i -e "/^all:/s/ \(chntpw\|reged\).static//g" Makefile || die
+ fi
+
+ emake clean
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -DUSEOPENSSL -Wall" \
+ LIBS="-lcrypto"
+}
+
+src_install() {
+ dobin chntpw cpnt reged
+
+ if use static; then
+ dobin {chntpw,reged}.static
+ fi
+
+ dodoc {HISTORY,README,regedit,WinReg}.txt
+}
diff --git a/app-crypt/chntpw/chntpw-140201.ebuild b/app-crypt/chntpw/chntpw-140201.ebuild
new file mode 100644
index 000000000000..97a56ace6e9e
--- /dev/null
+++ b/app-crypt/chntpw/chntpw-140201.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Offline Windows NT Password & Registry Editor"
+HOMEPAGE="http://pogostick.net/~pnh/ntpasswd/"
+SRC_URI="http://pogostick.net/~pnh/ntpasswd/${PN}-source-${PV}.zip"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static"
+
+RDEPEND="dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ static? ( dev-libs/openssl:0[static-libs] )"
+
+src_prepare() {
+ sed -i -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' Makefile || die
+
+ if ! use static ; then
+ sed -i -e "/^all:/s/ \(chntpw\|reged\).static//g" Makefile || die
+ fi
+
+ emake clean
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -DUSEOPENSSL -Wall" \
+ LIBS="-lcrypto"
+}
+
+src_install() {
+ dobin chntpw cpnt reged
+
+ if use static; then
+ dobin {chntpw,reged}.static
+ fi
+
+ dodoc {HISTORY,README,regedit,WinReg}.txt
+}
diff --git a/app-crypt/chntpw/metadata.xml b/app-crypt/chntpw/metadata.xml
new file mode 100644
index 000000000000..b02ffbb5d348
--- /dev/null
+++ b/app-crypt/chntpw/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+</pkgmetadata>