summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2016-09-25 03:40:02 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2016-09-25 03:40:02 +0000
commitd6a6f09430975191f3f7b500b128deb138a15b15 (patch)
treeacec0dee1911c32a928fa2024f1b6ce231df5d31
parentSecurity bump - addresses SA-CORE-2016-004 (bug 594718). Remove vulnerable ve... (diff)
downloadgentoo-d6a6f09430975191f3f7b500b128deb138a15b15.tar.gz
gentoo-d6a6f09430975191f3f7b500b128deb138a15b15.tar.bz2
gentoo-d6a6f09430975191f3f7b500b128deb138a15b15.zip
Add first 8.2.0 release candidate.
Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-8.2.0_rc1.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index c05c58ba230a..b11a4e180caa 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,3 +1,4 @@
DIST drupal-6.38.tar.gz 1113790 SHA256 46a6d7ec170e74f3c85b11fdf0fae74ce0691d4260b848bf5faff1f0f5f31d4b SHA512 ad8b0e04c15afa6e5b5f7d60478c7ac7f6123cd0735424588a4266a987d13df96d8349a8674bcdbcfc437a63847269477a6c836660b7dd990dbb1b844809ce14 WHIRLPOOL 87df66cb65bd9c97356f54d9ede14a6bec41aed49cdb5ae0f504077ce14f03cecb03ace863492c765c3b3837d8aa84c12bf11ed3ebf874afac1b69c21d31661b
DIST drupal-7.50.tar.gz 3286826 SHA256 82041716e1790269d09ec4a1c4cca8899d0221509471d53ac793a320143e0cf0 SHA512 1d80c1cb46db4a679f4ba61decfd799989c915206325a825e0c2234c33d84dc4a7ee38a76f51e48337e241c22deffc0589d65eb6de4341070e1b4440823e52c3 WHIRLPOOL eaf8a872c505a8be8faba3f8e687360c7f52e09fbf081fbd2141245a13220ac16de67bb4a7c1a283d61c517760df54bb2a268bf67649ea0875be48bd89bb6573
DIST drupal-8.1.10.tar.gz 12651446 SHA256 6bacd17843a23f5079171023cdef6fc03616cf9682c0af898649232c0a6262cb SHA512 22e27a339b2fff40b99549617480f1ca5525b8103b0ceb85e267b13ac6bd1703c06db63c1bb8bf6a85ba3ad1e178e3bf0fc04bbaf26bb96b1950c6d032181e16 WHIRLPOOL dfaa9900a96e2ec01b5b3d19910d869323a8ff985080686e567dad8c7d3e570e3fecc5c34e2112e9f52f60c73b7139fb99f7bc06f463c89872b1375d3c97390f
+DIST drupal-8.2.0-rc1.tar.gz 12854953 SHA256 6d8b7c3f5009fde60beb2dc02cd3c8b9e36413dd95b30a4af7d80a3b7463aa25 SHA512 6f73da6c25eb3c40c9f0df88ab6bf785ee0ef9ba48b51ad246d0cd16019c6d269027fb853f9490741031fecf1a046d16c119fc61cc6568738d3cc639dabb7a0f WHIRLPOOL 291e6bb4bc5d97c691019ef3211b88c0303d60be97e4f4b3b5be1b78186fb8c93cca1bf2b398359ad7df0c640e4bad840185915c7d57874fe44a2d41a9d76dda
diff --git a/www-apps/drupal/drupal-8.2.0_rc1.ebuild b/www-apps/drupal/drupal-8.2.0_rc1.ebuild
new file mode 100644
index 000000000000..0eab0019504f
--- /dev/null
+++ b/www-apps/drupal/drupal-8.2.0_rc1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}