summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-05-23 19:29:54 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-23 19:30:10 +0300
commit98ec6347fb3c877e4342a24297aabf35096c72ce (patch)
tree93a11485bea80f4c121276d25e934109e88d9e85
parentgui-wm/wayfire: Drop old versions (diff)
downloadgentoo-98ec6347fb3c877e4342a24297aabf35096c72ce.tar.gz
gentoo-98ec6347fb3c877e4342a24297aabf35096c72ce.tar.bz2
gentoo-98ec6347fb3c877e4342a24297aabf35096c72ce.zip
app-shells/liquidprompt: add 2.2.0
Closes: https://bugs.gentoo.org/849224 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-shells/liquidprompt/Manifest2
-rw-r--r--app-shells/liquidprompt/liquidprompt-2.2.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/app-shells/liquidprompt/Manifest b/app-shells/liquidprompt/Manifest
index 54d0615edb1b..141d3966408d 100644
--- a/app-shells/liquidprompt/Manifest
+++ b/app-shells/liquidprompt/Manifest
@@ -1 +1,3 @@
+DIST bash-preexec.sh 12667 BLAKE2B 1a19e3d7c2b74ae7572375b7af11c20a3506464c1ae31b90439529422ae74fcdb26f71bfa3d9128180852b511335cd79a9ab3d951aa9d4d1749c122cd3444013 SHA512 c77093d7049ad97406519e3f7bd98dbfa6ca3670c635995484aa5635a47e0243c885868dc48bb89d9f15d2c8082657eefb895e1fb764c3b9e0498cfee7797120
DIST liquidprompt-2.1.2.tar.gz 621356 BLAKE2B b5c3c52179f86fc42164e08a01f4e114f5e7ce1cdb5fb19ef1c02e85569e895cb5f1cc2f61bf6f66380d5c20bc6daf41547eb281990221528d5c1d85b61d1329 SHA512 685da50d347ba0d7c6881d87426344840cc7ab960067035b43f9658c51d7d5cf89e80f4bf8344b49f3858fe91bcfd57dcfaf9a253246fc1a7ebedbba474dc5ff
+DIST liquidprompt-2.2.0.tar.gz 986151 BLAKE2B aad40582ddb3e4f611e4632ebff0a6625d169a18d35013d204b1912196c770f04361a617c54e3c798b9828fba3919c0af328f81e1994ba3c987321b551ed9634 SHA512 1ccefcdb7b58697ac9b27e3e94ef1527c17ac36e9e405930f5b8b2a906cad5789ed9f77271dbcc66b3ef3457b307df370cfc60f88dc13e9d82ba3de7e2708421
diff --git a/app-shells/liquidprompt/liquidprompt-2.2.0.ebuild b/app-shells/liquidprompt/liquidprompt-2.2.0.ebuild
new file mode 100644
index 000000000000..8aae627d6efa
--- /dev/null
+++ b/app-shells/liquidprompt/liquidprompt-2.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Full-featured & carefully designed adaptive prompt for Bash & Zsh"
+HOMEPAGE="https://github.com/nojhan/liquidprompt https://liquidprompt.readthedocs.io/"
+SRC_URI="
+ https://github.com/nojhan/liquidprompt/releases/download/v${PV}/${PN}-v${PV}.tar.gz
+ -> ${P}.tar.gz
+ test? (
+ https://raw.githubusercontent.com/rcaloras/bash-preexec/0.4.1/bash-preexec.sh
+ )
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-util/shunit2 )"
+
+DOCS=( CHANGELOG.md example.bashrc README.md )
+
+src_test() {
+ cp "${DISTDIR}/bash-preexec.sh" tests/ || die
+ cp "$(type -P shunit2)" tests/shunit2 || die
+ ./tests.sh bash || die
+}
+
+src_install() {
+ default
+ dobin liquidprompt
+
+ insinto /usr/share/${PN}
+ doins -r themes templates tools
+
+ insinto /etc/
+ ./tools/config-from-doc.sh > "${T}/liquidpromptrc" || die
+ newins "${T}/liquidpromptrc" liquidpromptrc
+}