summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '0018-build-suppress-GNU-ld-warning-about-RWX-load-segment.patch')
-rw-r--r--0018-build-suppress-GNU-ld-warning-about-RWX-load-segment.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/0018-build-suppress-GNU-ld-warning-about-RWX-load-segment.patch b/0018-build-suppress-GNU-ld-warning-about-RWX-load-segment.patch
new file mode 100644
index 0000000..87a0873
--- /dev/null
+++ b/0018-build-suppress-GNU-ld-warning-about-RWX-load-segment.patch
@@ -0,0 +1,35 @@
+From 4890031d224262a6cf43d3bef1af4a16c13db306 Mon Sep 17 00:00:00 2001
+From: Jan Beulich <jbeulich@suse.com>
+Date: Tue, 7 Jun 2022 14:06:51 +0200
+Subject: [PATCH 18/32] build: suppress GNU ld warning about RWX load segments
+
+We cannot really avoid such and we're also not really at risk because of
+them, as we control page table permissions ourselves rather than relying
+on a loader of some sort. Present GNU ld master started warning about
+such, and hence 2.39 is anticipated to have this warning.
+
+Signed-off-by: Jan Beulich <jbeulich@suse.com>
+Acked-by: Andrew Cooper <andrew.cooper3@citrix.com>
+Acked-by: Julien Grall <jgrall@amazon.com>
+master commit: 68f5aac012b9ae36ce9b65d9ca9cc9f232191ad3
+master date: 2022-05-18 11:17:19 +0200
+---
+ xen/Makefile | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/xen/Makefile b/xen/Makefile
+index ce4eca3ee4d7..4d9abe704628 100644
+--- a/xen/Makefile
++++ b/xen/Makefile
+@@ -260,6 +260,8 @@ endif
+
+ AFLAGS += -D__ASSEMBLY__
+
++LDFLAGS-$(call ld-option,--warn-rwx-segments) += --no-warn-rwx-segments
++
+ CFLAGS += $(CFLAGS-y)
+ # allow extra CFLAGS externally via EXTRA_CFLAGS_XEN_CORE
+ CFLAGS += $(EXTRA_CFLAGS_XEN_CORE)
+--
+2.35.1
+