summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '006-vim-8.0.0617-crosscompile.patch')
-rw-r--r--006-vim-8.0.0617-crosscompile.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/006-vim-8.0.0617-crosscompile.patch b/006-vim-8.0.0617-crosscompile.patch
new file mode 100644
index 0000000..8328171
--- /dev/null
+++ b/006-vim-8.0.0617-crosscompile.patch
@@ -0,0 +1,22 @@
+Skip failing configure checks during cross-compile builds (bug #473372).
+
+--- vim-8.0.0617/src/configure.ac
++++ vim-8.0.0617/src/configure.ac
+@@ -3303,7 +3303,7 @@
+ # include <stddef.h>
+ #endif
+ main() {char *s; s=(char *)tgoto("%p1%d", 0, 1); exit(0); }],
+- res="OK", res="FAIL", res="FAIL")
++ res="OK", res="FAIL", res="OK")
+ if test "$res" = "OK"; then
+ break
+ fi
+@@ -3373,7 +3373,7 @@
+ ],[
+ vim_cv_tgent=non-zero
+ ],[
+- AC_MSG_ERROR(failed to compile test program.)
++ vim_cv_tgent=zero
+ ])
+ ])
+