aboutsummaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* Remove symbol.id_listAlexey Zaytsev2008-06-111-1/+1
| | | | | | | It was only used to check if the symbol was already bound, and would cause significant complication in the serialization code. Signed-off-by: Alexey Zaytsev <alexey.zaytsev@gmail.com>
* [PATCH] file and global scopes are the same for purposes of struct redefiningAl Viro2007-07-291-0/+10
| | | | Signed-off-by: Al Viro <viro@zeniv.linux.org.uk>
* Fix typos in commentsJosh Triplett2007-03-091-1/+1
| | | | Signed-off-by: Josh Triplett <josh@freedesktop.org>
* kill NS_INVISIBLEMACRO, introduce NS_UNDEFOleg Nesterov2006-12-051-7/+0
| | | | | | | | With this patch handle_undef() doesn't corrupt the builtin macros. This (imho) cleanups the code and is used in the next patches. Signed-off-by: Oleg Nesterov <oleg@tv-sign.ru>
* delay removing file scopeChristopher Li2006-12-041-0/+7
| | | | | | | | | | | Sparse only returns the used symbol. By the time it return the symbol, it already destroyed the file scope. This patch preserve the file scope. The caller can examine the unused symbols. e.g. If I want to generate ctags base on sparse, it need those unused symbols. Signed-off-by: Christopher Li <sparse@chrisli.org>
* Update the calling interface to "sparse()".Linus Torvalds2005-08-031-5/+9
| | | | | | | | | | | | | | Start off with sparse_initialize(argc, argv); which will return the number of filenames found. You can then use that, or just check if *argv is NULL in a loop like while (*argv) list = sparse(argv); where you get the declaration list for each file in turn.
* Make types have file scope, not global scopeLinus Torvalds2005-08-021-3/+3
| | | | Only actual global variables have global scope.
* Make macros have file scopeLinus Torvalds2005-08-021-1/+11
| | | | | Also, macros are special: they can be removed out of scope with #undef, which makes them slightly more interesting when we exit the scope.
* Start work on proper scoping with multiple filesLinus Torvalds2005-08-021-4/+17
| | | | | | Brought on by a query from Mitesh Shah. I claimed it should be easy, let's see if I was full of sh*t (this is just some very early infrastructure, not the whole thing by any means!)
* Split out the blob allocator from lib.c into allocate.c.Linus Torvalds2005-04-071-0/+1
| | | | | | | | | It's disgusting how intimate lib.c is with all the types, and this is slowly trying to split things up a bit. Now the intimate part is in allocate.c, but maybe we can get to the point where each allocation user just declares its own allocation strategy, and just uses the generic routines in allocate.c
* Update copyright notices a bit.Linus Torvalds2005-04-071-1/+1
|
* Make END_FOR_EACH_PTR[_REVERSE] take the ptr name as an argument.Linus Torvalds2005-04-071-1/+1
| | | | | | ..and switch us entirely over to the new naming scheme. All the nasty work of going through the users thanks to Chris Li.
* Update copyright notices to reflect the fact that TransmetaLinus Torvalds2005-04-071-0/+1
| | | | isn't the sole copyright owner these days.
* More conversion from "iterate()" to an explicit FOR_EACH_PTR()Linus Torvalds2005-04-071-2/+5
| | | | | | | | loop. In particular, this cleans up the compound statement return type handling a lot. It's just a lot more obvious with the straigth loop, and no indirection through an iterator function.
* Do a proper scope allocator, don't use the "bytes" allocator that doesn'tLinus Torvalds2005-04-071-1/+1
| | | | have any alignment guarantees.
* Start updating the copyright license comments to the OSL,Linus Torvalds2005-04-071-1/+3
| | | | preparing for a public release.
* Oops. Bad scoping for iterators and switch() statements. We didn'tLinus Torvalds2005-04-071-0/+1
| | | | | | | | | close the scope properly at the end (we started a new one instead). Make all non-static functions external. And always check the declarator against previous symbols when finding a new symbol. We want to verify that we don't have duplicates.
* Expose scoping to symbol binders - we'll need this to checkLinus Torvalds2005-04-071-8/+6
| | | | | whether it is a re-definition (ie new declaration in the same scope).
* Change the copyright to Transmeta Corp, that's likely to beLinus Torvalds2005-04-071-1/+1
| | | | the real one when it goes out the door.
* Separate scopes for blocks and functions. Function scopesLinus Torvalds2005-04-071-8/+34
| | | | | | | | are a proper superset of block scopes: function scopes are created by a new function, block scopes by compound statements and statement expressions. Make labels use function scope.
* Add copyright statements and file comments. Add a FAQ, README, andLinus Torvalds2005-04-071-0/+2
| | | | placeholder LICENSE file.
* Make iterators take a helper datum, and tell the callback whetherLinus Torvalds2005-04-071-2/+2
| | | | | | the entry is the first or last. Make printouts prettier by using the new iterator functionality.
* Add symbol scoping for proper parsing.Linus Torvalds2005-04-071-0/+47