summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--0000_README4
-rw-r--r--1156_linux-4.19.157.patch29
2 files changed, 33 insertions, 0 deletions
diff --git a/0000_README b/0000_README
index 54a0fb2a..6ed22675 100644
--- a/0000_README
+++ b/0000_README
@@ -663,6 +663,10 @@ Patch: 1155_linux-4.19.156.patch
From: https://www.kernel.org
Desc: Linux 4.19.156
+Patch: 1156_linux-4.19.157.patch
+From: https://www.kernel.org
+Desc: Linux 4.19.157
+
Patch: 1500_XATTR_USER_PREFIX.patch
From: https://bugs.gentoo.org/show_bug.cgi?id=470644
Desc: Support for namespace user.pax.* on tmpfs.
diff --git a/1156_linux-4.19.157.patch b/1156_linux-4.19.157.patch
new file mode 100644
index 00000000..7ce30a41
--- /dev/null
+++ b/1156_linux-4.19.157.patch
@@ -0,0 +1,29 @@
+diff --git a/Makefile b/Makefile
+index 82891b34e19e0..245bcd8dd7b72 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ # SPDX-License-Identifier: GPL-2.0
+ VERSION = 4
+ PATCHLEVEL = 19
+-SUBLEVEL = 156
++SUBLEVEL = 157
+ EXTRAVERSION =
+ NAME = "People's Front"
+
+diff --git a/drivers/powercap/powercap_sys.c b/drivers/powercap/powercap_sys.c
+index 9e2f274bd44f2..60c8375c3c816 100644
+--- a/drivers/powercap/powercap_sys.c
++++ b/drivers/powercap/powercap_sys.c
+@@ -379,9 +379,9 @@ static void create_power_zone_common_attributes(
+ &dev_attr_max_energy_range_uj.attr;
+ if (power_zone->ops->get_energy_uj) {
+ if (power_zone->ops->reset_energy_uj)
+- dev_attr_energy_uj.attr.mode = S_IWUSR | S_IRUGO;
++ dev_attr_energy_uj.attr.mode = S_IWUSR | S_IRUSR;
+ else
+- dev_attr_energy_uj.attr.mode = S_IRUGO;
++ dev_attr_energy_uj.attr.mode = S_IRUSR;
+ power_zone->zone_dev_attrs[count++] =
+ &dev_attr_energy_uj.attr;
+ }