aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@redhat.com>2005-11-02 13:19:10 +0000
committerDaniel Veillard <veillard@redhat.com>2005-11-02 13:19:10 +0000
commitb8e381131ca1a5b38b660be48adf0bef0228c6da (patch)
tree8140117562a4cd5ebe733b7c22e3c0a9490a9923 /configure.in
parentInitial revision (diff)
downloadlibvirt-b8e381131ca1a5b38b660be48adf0bef0228c6da.tar.gz
libvirt-b8e381131ca1a5b38b660be48adf0bef0228c6da.tar.bz2
libvirt-b8e381131ca1a5b38b660be48adf0bef0228c6da.zip
* AUTHORS NEWS README autogen.sh configure.in: allow autogen.sh and
configure to start working * src/Makefile.am src/internal.h src/libxen.c: make the first compile Daniel
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5b5c9c92b..6178060ec 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(entities.c)
+AC_INIT(src/libxen.c)
AM_CONFIG_HEADER(config.h)
AC_CANONICAL_HOST
@@ -33,3 +33,21 @@ VERSION=${LIBXEN_VERSION}
AM_INIT_AUTOMAKE(libxen, $VERSION)
+dnl Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_CPP
+AC_PATH_PROG(RM, rm, /bin/rm)
+AC_PATH_PROG(MV, mv, /bin/mv)
+AC_PATH_PROG(TAR, tar, /bin/tar)
+
+dnl Make sure we have an ANSI compiler
+AM_C_PROTOTYPES
+test "x$U" != "x" && AC_MSG_ERROR(Compiler not ANSI compliant)
+
+AM_PROG_LIBTOOL
+
+dnl search for the low level Xen library
+AC_SEARCH_LIBS(xc_domain_create, [xenctrl])
+
+AC_OUTPUT(Makefile src/Makefile)