aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2012-07-18 12:42:38 +0100
committerDaniel P. Berrange <berrange@redhat.com>2012-07-18 19:34:26 +0100
commitdf5232f5546592f09667c172cf18b52a80f13f6f (patch)
tree84187153387f03b91f647878fccf6c1d55df0d08
parentReplace use of virSecretReportError with virReportError (diff)
downloadlibvirt-df5232f5546592f09667c172cf18b52a80f13f6f.tar.gz
libvirt-df5232f5546592f09667c172cf18b52a80f13f6f.tar.bz2
libvirt-df5232f5546592f09667c172cf18b52a80f13f6f.zip
Replace use of virNodeDeviceReportError with virReportError
Update the node device driver to use virReportError instead of the virNodeDeviceReportError custom macro Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
-rw-r--r--cfg.mk1
-rw-r--r--src/node_device/node_device_driver.c42
-rw-r--r--src/node_device/node_device_driver.h4
-rw-r--r--src/node_device/node_device_udev.c6
4 files changed, 24 insertions, 29 deletions
diff --git a/cfg.mk b/cfg.mk
index d1a6d233a..f2a7e29a8 100644
--- a/cfg.mk
+++ b/cfg.mk
@@ -541,7 +541,6 @@ msg_gen_function += virLibNWFilterError
msg_gen_function += virLibSecretError
msg_gen_function += virLibStoragePoolError
msg_gen_function += virLibStorageVolError
-msg_gen_function += virNodeDeviceReportError
msg_gen_function += virNWFilterReportError
msg_gen_function += virRaiseError
msg_gen_function += virReportError
diff --git a/src/node_device/node_device_driver.c b/src/node_device/node_device_driver.c
index b0a29cdd4..83db775d6 100644
--- a/src/node_device/node_device_driver.c
+++ b/src/node_device/node_device_driver.c
@@ -196,7 +196,7 @@ nodeDeviceLookupByName(virConnectPtr conn, const char *name)
nodeDeviceUnlock(driver);
if (!obj) {
- virNodeDeviceReportError(VIR_ERR_NO_NODE_DEVICE, NULL);
+ virReportError(VIR_ERR_NO_NODE_DEVICE, NULL);
goto cleanup;
}
@@ -271,9 +271,9 @@ nodeDeviceGetXMLDesc(virNodeDevicePtr dev,
nodeDeviceUnlock(driver);
if (!obj) {
- virNodeDeviceReportError(VIR_ERR_NO_NODE_DEVICE,
- _("no node device with matching name '%s'"),
- dev->name);
+ virReportError(VIR_ERR_NO_NODE_DEVICE,
+ _("no node device with matching name '%s'"),
+ dev->name);
goto cleanup;
}
@@ -301,9 +301,9 @@ nodeDeviceGetParent(virNodeDevicePtr dev)
nodeDeviceUnlock(driver);
if (!obj) {
- virNodeDeviceReportError(VIR_ERR_NO_NODE_DEVICE,
- _("no node device with matching name '%s'"),
- dev->name);
+ virReportError(VIR_ERR_NO_NODE_DEVICE,
+ _("no node device with matching name '%s'"),
+ dev->name);
goto cleanup;
}
@@ -312,8 +312,8 @@ nodeDeviceGetParent(virNodeDevicePtr dev)
if (!ret)
virReportOOMError();
} else {
- virNodeDeviceReportError(VIR_ERR_INTERNAL_ERROR,
- "%s", _("no parent for this device"));
+ virReportError(VIR_ERR_INTERNAL_ERROR,
+ "%s", _("no parent for this device"));
}
cleanup:
@@ -337,9 +337,9 @@ nodeDeviceNumOfCaps(virNodeDevicePtr dev)
nodeDeviceUnlock(driver);
if (!obj) {
- virNodeDeviceReportError(VIR_ERR_NO_NODE_DEVICE,
- _("no node device with matching name '%s'"),
- dev->name);
+ virReportError(VIR_ERR_NO_NODE_DEVICE,
+ _("no node device with matching name '%s'"),
+ dev->name);
goto cleanup;
}
@@ -368,9 +368,9 @@ nodeDeviceListCaps(virNodeDevicePtr dev, char **const names, int maxnames)
nodeDeviceUnlock(driver);
if (!obj) {
- virNodeDeviceReportError(VIR_ERR_NO_NODE_DEVICE,
- _("no node device with matching name '%s'"),
- dev->name);
+ virReportError(VIR_ERR_NO_NODE_DEVICE,
+ _("no node device with matching name '%s'"),
+ dev->name);
goto cleanup;
}
@@ -414,8 +414,8 @@ nodeDeviceVportCreateDelete(const int parent_host,
operation_file = LINUX_SYSFS_VPORT_DELETE_POSTFIX;
break;
default:
- virNodeDeviceReportError(VIR_ERR_INTERNAL_ERROR,
- _("Invalid vport operation (%d)"), operation);
+ virReportError(VIR_ERR_INTERNAL_ERROR,
+ _("Invalid vport operation (%d)"), operation);
retval = -1;
goto cleanup;
break;
@@ -487,8 +487,8 @@ get_time(time_t *t)
*t = time(NULL);
if (*t == (time_t)-1) {
- virNodeDeviceReportError(VIR_ERR_INTERNAL_ERROR,
- "%s", _("Could not get current time"));
+ virReportError(VIR_ERR_INTERNAL_ERROR,
+ "%s", _("Could not get current time"));
*t = 0;
ret = -1;
@@ -593,7 +593,7 @@ nodeDeviceCreateXML(virConnectPtr conn,
* we're returning what we get... */
if (dev == NULL) {
- virNodeDeviceReportError(VIR_ERR_NO_NODE_DEVICE, NULL);
+ virReportError(VIR_ERR_NO_NODE_DEVICE, NULL);
}
cleanup:
@@ -619,7 +619,7 @@ nodeDeviceDestroy(virNodeDevicePtr dev)
nodeDeviceUnlock(driver);
if (!obj) {
- virNodeDeviceReportError(VIR_ERR_NO_NODE_DEVICE, NULL);
+ virReportError(VIR_ERR_NO_NODE_DEVICE, NULL);
goto out;
}
diff --git a/src/node_device/node_device_driver.h b/src/node_device/node_device_driver.h
index c94e8706c..673e95b3a 100644
--- a/src/node_device/node_device_driver.h
+++ b/src/node_device/node_device_driver.h
@@ -28,10 +28,6 @@
# include "driver.h"
# include "node_device_conf.h"
-# define virNodeDeviceReportError(code, ...) \
- virReportErrorHelper(VIR_FROM_NODEDEV, code, __FILE__, \
- __FUNCTION__, __LINE__, __VA_ARGS__)
-
# define LINUX_SYSFS_SCSI_HOST_PREFIX "/sys/class/scsi_host/"
# define LINUX_SYSFS_SCSI_HOST_POSTFIX "device"
# define LINUX_SYSFS_FC_HOST_PREFIX "/sys/class/fc_host/"
diff --git a/src/node_device/node_device_udev.c b/src/node_device/node_device_udev.c
index 6418015a5..aa96abdb2 100644
--- a/src/node_device/node_device_udev.c
+++ b/src/node_device/node_device_udev.c
@@ -1241,9 +1241,9 @@ static int udevSetParent(struct udev_device *device,
parent_sysfs_path = udev_device_get_syspath(parent_device);
if (parent_sysfs_path == NULL) {
- virNodeDeviceReportError(VIR_ERR_INTERNAL_ERROR,
- _("Could not get syspath for parent of '%s'"),
- udev_device_get_syspath(parent_device));
+ virReportError(VIR_ERR_INTERNAL_ERROR,
+ _("Could not get syspath for parent of '%s'"),
+ udev_device_get_syspath(parent_device));
goto out;
}