aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kolourpaint')
-rw-r--r--kde-apps/kolourpaint/Manifest1
-rw-r--r--kde-apps/kolourpaint/kolourpaint-22.04.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/kde-apps/kolourpaint/Manifest b/kde-apps/kolourpaint/Manifest
new file mode 100644
index 0000000000..2e5ceb13fe
--- /dev/null
+++ b/kde-apps/kolourpaint/Manifest
@@ -0,0 +1 @@
+DIST kolourpaint-22.04.1.tar.xz 5716732 BLAKE2B d37f00378f685dba860d04bd9e159fe6abb19964301e9c9cc67cb6b0d5b7e622190681b066319dd298dba0eed61463b2ea63ccdb089b85798b33772b0e22f305 SHA512 1cf4e03ada2d4b54db533ac46589dddd1f11e72a558f1cc1d633644d1d0718dd52cfc7cb14d07960e68eed5b34e39d582b3549eaf9e87c33d8a9dffcc0c8b9ca
diff --git a/kde-apps/kolourpaint/kolourpaint-22.04.1.ebuild b/kde-apps/kolourpaint/kolourpaint-22.04.1.ebuild
new file mode 100644
index 0000000000..38162134d2
--- /dev/null
+++ b/kde-apps/kolourpaint/kolourpaint-22.04.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.92.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Paint Program by KDE"
+HOMEPAGE="https://apps.kde.org/kolourpaint/"
+
+LICENSE="BSD-2 LGPL-2 LGPL-2+ || ( LGPL-2.1 LGPL-3 ) GPL-2 handbook? ( FDL-1.2 )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="scanner"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ scanner? ( >=kde-apps/libksane-${PVCUT}:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package scanner KF5Sane)
+ )
+
+ ecm_src_configure
+}