aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2006-01-05 23:54:12 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2006-01-05 23:54:12 +0000
commit8b219b58c4ece7d69afa1adc0639bf7cc822d74c (patch)
tree40c11d27078c713ca8546b905eb11f0e08094104
parentMake it clearer how to get more shutdown/wakeup-methods. (diff)
downloadgentoo-vdr-scripts-8b219b58c4ece7d69afa1adc0639bf7cc822d74c.tar.gz
gentoo-vdr-scripts-8b219b58c4ece7d69afa1adc0639bf7cc822d74c.tar.bz2
gentoo-vdr-scripts-8b219b58c4ece7d69afa1adc0639bf7cc822d74c.zip
moved include-files
svn path=/gentoo-vdr-scripts/trunk/; revision=121
-rw-r--r--ChangeLog11
-rw-r--r--Makefile3
-rwxr-xr-xetc/init.d/vdr3
-rw-r--r--usr/lib/vdr/bin/vdrshutdown-gate.sh2
-rw-r--r--usr/lib/vdr/bin/vdrshutdown-periodic-thread.sh2
-rw-r--r--usr/lib/vdr/bin/vdrshutdown-really.sh2
-rw-r--r--usr/lib/vdr/inc/rc-functions.sh (renamed from usr/lib/vdr/rcscript/functions.sh)0
-rw-r--r--usr/lib/vdr/inc/shutdown-functions.sh (renamed from usr/lib/vdr/rcscript/functions-shutdown.sh)0
-rw-r--r--usr/lib/vdr/rcscript/pre-start-50-shutdown.sh2
9 files changed, 19 insertions, 6 deletions
diff --git a/ChangeLog b/ChangeLog
index 2d8bfd1..8ff40fd 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for gentoo-vdr-scripts
05 Jan 2006; Matthias Schwarzott <zzam@gentoo.org>
+ usr/lib/vdr/rcscript/pre-start-50-shutdown.sh, Makefile,
+ etc/init.d/vdr, usr/lib/vdr/bin/vdrshutdown-gate.sh,
+ usr/lib/vdr/bin/vdrshutdown-periodic-thread.sh,
+ usr/lib/vdr/bin/vdrshutdown-really.sh,
+ +usr/lib/vdr/inc/shutdown-functions.sh,
+ -usr/lib/vdr/rcscript/functions-shutdown.sh
+ +usr/lib/vdr/inc/rc-functions.sh
+ --usr/lib/vdr/rcscript/functions.sh:
+ moved include-files
+
+ 05 Jan 2006; Matthias Schwarzott <zzam@gentoo.org>
usr/lib/vdr/rcscript/pre-start-50-shutdown.sh:
Make it clearer how to get more shutdown/wakeup-methods.
diff --git a/Makefile b/Makefile
index 1236d58..d4a2aa0 100644
--- a/Makefile
+++ b/Makefile
@@ -23,6 +23,9 @@ install:
install -m 0644 -o root -g root usr/lib/vdr/shutdown/{shutdown,pre,periodic}*.sh $(DESTDIR)/usr/lib/vdr/shutdown/
install -m 0644 -o root -g root usr/lib/vdr/shutdown/wakeup-acpi.sh $(DESTDIR)/usr/lib/vdr/shutdown/
+ mkdir -p $(DESTDIR)/usr/lib/vdr/inc
+ install -m 0644 -o root -g root usr/lib/vdr/inc/*.sh $(DESTDIR)/usr/lib/vdr/inc/
+
mkdir -p $(DESTDIR)/usr/lib/vdr/record
install -m 0644 -o root -g root usr/lib/vdr/record/*.sh $(DESTDIR)/usr/lib/vdr/record/
diff --git a/etc/init.d/vdr b/etc/init.d/vdr
index 4632f30..030af75 100755
--- a/etc/init.d/vdr
+++ b/etc/init.d/vdr
@@ -4,8 +4,7 @@
opts="${opts} watchdogrestart"
-vdr_rcdir=/usr/lib/vdr/rcscript
-source ${vdr_rcdir}/functions.sh
+source /usr/lib/vdr/inc/rc-functions.sh
depend() {
use lircd dvbsplash
diff --git a/usr/lib/vdr/bin/vdrshutdown-gate.sh b/usr/lib/vdr/bin/vdrshutdown-gate.sh
index 7e84c76..e8fae42 100644
--- a/usr/lib/vdr/bin/vdrshutdown-gate.sh
+++ b/usr/lib/vdr/bin/vdrshutdown-gate.sh
@@ -11,7 +11,7 @@ SVDRPCMD=/usr/bin/svdrpsend.pl
NVRAM_WAKEUP=/usr/bin/nvram-wakeup
HOOKDIR=/usr/lib/vdr/shutdown
-source /usr/lib/vdr/rcscript/functions-shutdown.sh
+source /usr/lib/vdr/inc/shutdown-functions.sh
read_shutdown_config
source /usr/lib/vdr/rcscript/vdr-capabilities.sh
diff --git a/usr/lib/vdr/bin/vdrshutdown-periodic-thread.sh b/usr/lib/vdr/bin/vdrshutdown-periodic-thread.sh
index e331140..4ff292a 100644
--- a/usr/lib/vdr/bin/vdrshutdown-periodic-thread.sh
+++ b/usr/lib/vdr/bin/vdrshutdown-periodic-thread.sh
@@ -1,5 +1,5 @@
#!/bin/bash
-source /usr/lib/vdr/rcscript/functions-shutdown.sh
+source /usr/lib/vdr/inc/shutdown-functions.sh
source /usr/lib/vdr/rcscript/vdr-capabilities.sh
diff --git a/usr/lib/vdr/bin/vdrshutdown-really.sh b/usr/lib/vdr/bin/vdrshutdown-really.sh
index 6549667..190f511 100644
--- a/usr/lib/vdr/bin/vdrshutdown-really.sh
+++ b/usr/lib/vdr/bin/vdrshutdown-really.sh
@@ -3,7 +3,7 @@
# Matthias Schwarzott <zzam@gmx.de>
#
-source /usr/lib/vdr/rcscript/functions-shutdown.sh
+source /usr/lib/vdr/inc/shutdown-functions.sh
if [[ "${UID}" != "0" ]]; then
echo "This program should be run as root"
diff --git a/usr/lib/vdr/rcscript/functions.sh b/usr/lib/vdr/inc/rc-functions.sh
index 9b5e246..9b5e246 100644
--- a/usr/lib/vdr/rcscript/functions.sh
+++ b/usr/lib/vdr/inc/rc-functions.sh
diff --git a/usr/lib/vdr/rcscript/functions-shutdown.sh b/usr/lib/vdr/inc/shutdown-functions.sh
index 037a8c6..037a8c6 100644
--- a/usr/lib/vdr/rcscript/functions-shutdown.sh
+++ b/usr/lib/vdr/inc/shutdown-functions.sh
diff --git a/usr/lib/vdr/rcscript/pre-start-50-shutdown.sh b/usr/lib/vdr/rcscript/pre-start-50-shutdown.sh
index 4e62ca1..f05bd53 100644
--- a/usr/lib/vdr/rcscript/pre-start-50-shutdown.sh
+++ b/usr/lib/vdr/rcscript/pre-start-50-shutdown.sh
@@ -16,7 +16,7 @@ shutdown_disabled() {
}
addon_main() {
- source /usr/lib/vdr/rcscript/functions-shutdown.sh
+ source /usr/lib/vdr/inc/shutdown-functions.sh
read_shutdown_config
[[ "${SHUTDOWN_ACTIVE}" == "no" ]] && return