aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-05-07 19:14:58 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-05-07 19:14:58 +0000
commitbad2a0e5c2b9c714eae03719d7b0bab716992148 (patch)
tree7db9567578184e3bcb4d0361373e69129e3daac1 /doc/Makefile.am
parentadd some more notes on how eclectic works (diff)
downloadeselect-bad2a0e5c2b9c714eae03719d7b0bab716992148.tar.gz
eselect-bad2a0e5c2b9c714eae03719d7b0bab716992148.tar.bz2
eselect-bad2a0e5c2b9c714eae03719d7b0bab716992148.zip
make doc/Makefile.am much more generic
svn path=/trunk/; revision=49
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index a5e540e..64281e5 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,6 +1,12 @@
-noinst_DATA = developer-guide.txt
+doc_files = developer-guide
-html:
- for x in $(noinst_DATA) ; do \
- rst2html.py $${x} $${x%.*}.html ; \
- done
+noinst_DATA = $(foreach f, $(doc_files), $(f).txt)
+
+html: $(foreach f, $(doc_files), $(f).html )
+
+%.html : %.txt
+ rst2html.py < $? > $@
+
+CLEANFILES = $(foreach f, $(doc_files), $(f).html)
+MAINTAINERCLEANFILES = Makefile.in
+EXTRA_DIST = default.css $(noinst_DATA)