aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-15 09:33:40 +0200
committerAnthony G. Basile <blueness@gentoo.org>2018-11-28 16:34:51 -0500
commit9da9133383bae6e7d8e4c3b921e677fa73f5c410 (patch)
treef628c240c27b749960d1540218a1d2c41094d43b
parentPrepare release 0.9.2 (diff)
downloadelfix-9da9133383bae6e7d8e4c3b921e677fa73f5c410.tar.gz
elfix-9da9133383bae6e7d8e4c3b921e677fa73f5c410.tar.bz2
elfix-9da9133383bae6e7d8e4c3b921e677fa73f5c410.zip
attr/xattr.h is deprecated. Use sys/xattr.h instead
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--configure.ac4
-rw-r--r--scripts/paxmodule.c2
-rw-r--r--src/paxctl-ng.c5
3 files changed, 7 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 58bad71..9d84e09 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,9 +115,9 @@ AS_IF(
[test "x$enable_xtpax" != "xno"],
[
AC_CHECK_HEADERS(
- [attr/xattr.h],
+ [sys/xattr.h],
[],
- [AC_MSG_ERROR(["Missing necessary attr/xattr.h"])]
+ [AC_MSG_ERROR(["Missing necessary sys/xattr.h"])]
)
AC_CHECK_LIB(
[attr],
diff --git a/scripts/paxmodule.c b/scripts/paxmodule.c
index 1355f86..6a93420 100644
--- a/scripts/paxmodule.c
+++ b/scripts/paxmodule.c
@@ -45,7 +45,7 @@
#endif
#ifdef XTPAX
- #include <attr/xattr.h>
+ #include <sys/xattr.h>
#define PAX_NAMESPACE "user.pax.flags"
#endif
diff --git a/src/paxctl-ng.c b/src/paxctl-ng.c
index d340a43..25396d4 100644
--- a/src/paxctl-ng.c
+++ b/src/paxctl-ng.c
@@ -49,7 +49,10 @@
#endif
#ifdef XTPAX
- #include <attr/xattr.h>
+ #include <sys/xattr.h>
+ #ifndef ENOATTR
+ #define ENOATTR ENODATA
+ #endif
#define PAX_NAMESPACE "user.pax.flags"
#define CREATE_XT_FLAGS_SECURE 1
#define CREATE_XT_FLAGS_DEFAULT 2