aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <basile@opensource.dyc.edu>2011-04-25 16:29:47 -0400
committerAnthony G. Basile <basile@opensource.dyc.edu>2011-04-25 16:31:59 -0400
commite5a080221245ae53180b1a6a0abfe03cb6e0431c (patch)
tree8c0daa72cca08482749c7b02c6cd85232ef3b1a1
parentAdded contitional for 'tests' (diff)
downloadelfix-e5a080221245ae53180b1a6a0abfe03cb6e0431c.tar.gz
elfix-e5a080221245ae53180b1a6a0abfe03cb6e0431c.tar.bz2
elfix-e5a080221245ae53180b1a6a0abfe03cb6e0431c.zip
Fixed test on x86
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6ac6da6..a7fafde 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,7 +4,7 @@ bad_SOURCES = bad.c
bad_DEPENDENCIES = test-bad.o
bad_LDADD = test-bad.o
-ARCH = $(shell uname -m)
+ARCH = $(shell uname -m | sed -e 's/i./x/')
test-bad.o: test-bad64.asm test-bad32.asm
[[ "$(ARCH)" == "x86" ]] && yasm -f elf -m x86 test-bad32.asm && mv test-bad32.o test-bad.o || true