aboutsummaryrefslogtreecommitdiff
path: root/htl
diff options
context:
space:
mode:
authorgfleury <gfleury@disroot.org>2024-11-26 22:53:23 +0200
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2024-12-09 01:49:40 +0100
commitc982918e3ed0277564b152ab07ab0fa6efc8cfbd (patch)
tree0a13a6c06db48e37db1a44939bd21e310bec189c /htl
parentmath: Add sinpi,cospi,tanpi sparc64 ulps (diff)
downloadglibc-c982918e3ed0277564b152ab07ab0fa6efc8cfbd.tar.gz
glibc-c982918e3ed0277564b152ab07ab0fa6efc8cfbd.tar.bz2
glibc-c982918e3ed0277564b152ab07ab0fa6efc8cfbd.zip
htl: move pthread_condattr_destroy into libc.
Signed-off-by: gfleury <gfleury@disroot.org> Message-ID: <20241126205329.2215295-2-gfleury@disroot.org>
Diffstat (limited to 'htl')
-rw-r--r--htl/Makefile2
-rw-r--r--htl/Versions3
-rw-r--r--htl/forward.c1
-rw-r--r--htl/pt-initialize.c1
4 files changed, 3 insertions, 4 deletions
diff --git a/htl/Makefile b/htl/Makefile
index 25eb791031..2658f2470c 100644
--- a/htl/Makefile
+++ b/htl/Makefile
@@ -94,7 +94,6 @@ libpthread-routines := \
pt-rwlock-unlock \
pt-cond \
pt-condattr-init \
- pt-condattr-destroy \
pt-condattr-getclock \
pt-condattr-getpshared \
pt-condattr-setclock \
@@ -206,6 +205,7 @@ routines := \
pt-attr-setstack \
pt-attr-setstackaddr \
pt-attr-setstacksize \
+ pt-condattr-destroy \
pt-getschedparam \
pt-nthreads \
pt-pthread_self \
diff --git a/htl/Versions b/htl/Versions
index afc2495e2f..12399ba147 100644
--- a/htl/Versions
+++ b/htl/Versions
@@ -26,6 +26,7 @@ libc {
pthread_attr_setscope;
pthread_attr_setschedparam;
pthread_attr_init;
+ pthread_condattr_destroy;
}
GLIBC_2.21 {
@@ -119,7 +120,7 @@ libpthread {
pthread_cond_broadcast; pthread_cond_destroy; pthread_cond_init;
pthread_cond_signal; pthread_cond_timedwait; pthread_cond_wait;
- pthread_condattr_destroy; pthread_condattr_getclock;
+ pthread_condattr_getclock;
pthread_condattr_getpshared; pthread_condattr_init;
pthread_condattr_setclock; pthread_condattr_setpshared;
diff --git a/htl/forward.c b/htl/forward.c
index 7c0e16dc6e..3fe0a74d00 100644
--- a/htl/forward.c
+++ b/htl/forward.c
@@ -53,7 +53,6 @@ name decl \
#define FORWARD(name, decl, params, defretval) \
FORWARD2 (name, int, decl, params, return defretval)
-FORWARD (pthread_condattr_destroy, (pthread_condattr_t *attr), (attr), 0)
FORWARD (pthread_condattr_init, (pthread_condattr_t *attr), (attr), 0)
diff --git a/htl/pt-initialize.c b/htl/pt-initialize.c
index b082a13b54..632ee84773 100644
--- a/htl/pt-initialize.c
+++ b/htl/pt-initialize.c
@@ -27,7 +27,6 @@
#if IS_IN (libpthread)
static const struct pthread_functions pthread_functions = {
- .ptr_pthread_condattr_destroy = __pthread_condattr_destroy,
.ptr_pthread_condattr_init = __pthread_condattr_init,
.ptr_pthread_cond_broadcast = __pthread_cond_broadcast,
.ptr_pthread_cond_destroy = __pthread_cond_destroy,