aboutsummaryrefslogtreecommitdiff
path: root/htl
diff options
context:
space:
mode:
authorgfleury <gfleury@disroot.org>2024-12-31 15:49:03 +0200
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2025-01-01 23:46:19 +0100
commitbeabc5dff50230dfc9b5cda9448559952fdc470a (patch)
tree4748267ff87657c5ce301f76300360a04bf458ab /htl
parenthtl: move pthread_mutexattr_init into libc. (diff)
downloadglibc-beabc5dff50230dfc9b5cda9448559952fdc470a.tar.gz
glibc-beabc5dff50230dfc9b5cda9448559952fdc470a.tar.bz2
glibc-beabc5dff50230dfc9b5cda9448559952fdc470a.zip
htl: move pthread_mutexattr_destroy into libc.
Message-ID: <20241231134909.1166440-3-gfleury@disroot.org>
Diffstat (limited to 'htl')
-rw-r--r--htl/Makefile2
-rw-r--r--htl/Versions4
2 files changed, 4 insertions, 2 deletions
diff --git a/htl/Makefile b/htl/Makefile
index 5d1f7af378..e2b22af95f 100644
--- a/htl/Makefile
+++ b/htl/Makefile
@@ -54,7 +54,6 @@ libpthread-routines := \
pt-setcanceltype \
pt-testcancel \
pt-cancel \
- pt-mutexattr-destroy \
pt-mutexattr-getprioceiling \
pt-mutexattr-getprotocol \
pt-mutexattr-getpshared \
@@ -200,6 +199,7 @@ routines := \
pt-condattr-setpshared \
pt-getschedparam \
pt-mutex-checklocked \
+ pt-mutexattr-destroy \
pt-mutexattr-init \
pt-nthreads \
pt-pthread_self \
diff --git a/htl/Versions b/htl/Versions
index ae0e794919..d3ee842ebc 100644
--- a/htl/Versions
+++ b/htl/Versions
@@ -38,6 +38,7 @@ libc {
pthread_condattr_getpshared;
pthread_condattr_setclock;
pthread_condattr_setpshared;
+ pthread_mutexattr_destroy;
pthread_mutexattr_init;
pthread_sigmask;
}
@@ -115,6 +116,7 @@ libc {
__pthread_condattr_init;
__pthread_default_condattr;
__pthread_mutex_checklocked;
+ __pthread_mutexattr_destroy;
__pthread_mutexattr_init;
__pthread_sigstate;
__pthread_sigstate_destroy;
@@ -176,7 +178,7 @@ libpthread {
pthread_mutex_timedlock; pthread_mutex_transfer_np;
pthread_mutex_trylock; pthread_mutex_unlock;
- pthread_mutexattr_destroy; pthread_mutexattr_getprioceiling;
+ pthread_mutexattr_getprioceiling;
pthread_mutexattr_getprotocol; pthread_mutexattr_getpshared;
pthread_mutexattr_gettype;
pthread_mutexattr_setprioceiling; pthread_mutexattr_setprotocol;