aboutsummaryrefslogtreecommitdiff
path: root/htl
diff options
context:
space:
mode:
authorgfleury <gfleury@disroot.org>2024-12-19 22:37:22 +0200
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2024-12-22 23:34:27 +0100
commit917a131ab94f930ef5022f0042af95d931264b4a (patch)
treecf7e883e719bfb0b659ea56ff9f1c3aea2fcd791 /htl
parenthtl: move __pthread_wakeup into libc. (diff)
downloadglibc-917a131ab94f930ef5022f0042af95d931264b4a.tar.gz
glibc-917a131ab94f930ef5022f0042af95d931264b4a.tar.bz2
glibc-917a131ab94f930ef5022f0042af95d931264b4a.zip
htl: move pthread_cond_destroy into libc.
Signed-off-by: gfleury <gfleury@disroot.org> Message-ID: <20241219203727.669825-4-gfleury@disroot.org>
Diffstat (limited to 'htl')
-rw-r--r--htl/Makefile2
-rw-r--r--htl/Versions4
-rw-r--r--htl/forward.c1
-rw-r--r--htl/pt-initialize.c1
4 files changed, 4 insertions, 4 deletions
diff --git a/htl/Makefile b/htl/Makefile
index 168b211905..c61112d667 100644
--- a/htl/Makefile
+++ b/htl/Makefile
@@ -91,7 +91,6 @@ libpthread-routines := \
pt-rwlock-timedrdlock \
pt-rwlock-timedwrlock \
pt-rwlock-unlock \
- pt-cond-destroy \
pt-cond-brdcast \
pt-cond-signal \
pt-cond-wait \
@@ -195,6 +194,7 @@ routines := \
pt-attr-setstackaddr \
pt-attr-setstacksize \
pt-cond \
+ pt-cond-destroy \
pt-cond-init \
pt-condattr-destroy \
pt-condattr-getclock \
diff --git a/htl/Versions b/htl/Versions
index 996626df2f..30f7d03aeb 100644
--- a/htl/Versions
+++ b/htl/Versions
@@ -26,6 +26,7 @@ libc {
pthread_attr_setscope;
pthread_attr_setschedparam;
pthread_attr_init;
+ pthread_cond_destroy;
pthread_cond_init;
pthread_condattr_getclock;
pthread_condattr_init;
@@ -95,6 +96,7 @@ libc {
__pthread_attr_setstacksize;
__pthread_attr_setstackaddr;
__pthread_attr_setstack;
+ __pthread_cond_destroy;
__pthread_cond_init;
__pthread_condattr_init;
__pthread_default_condattr;
@@ -136,7 +138,7 @@ libpthread {
pthread_cancel;
- pthread_cond_broadcast; pthread_cond_destroy;
+ pthread_cond_broadcast;
pthread_cond_signal; pthread_cond_timedwait; pthread_cond_wait;
pthread_create; pthread_detach; pthread_exit;
diff --git a/htl/forward.c b/htl/forward.c
index eb83eaeda1..7731b84d04 100644
--- a/htl/forward.c
+++ b/htl/forward.c
@@ -54,7 +54,6 @@ name decl \
FORWARD2 (name, int, decl, params, return defretval)
FORWARD (pthread_cond_broadcast, (pthread_cond_t *cond), (cond), 0)
-FORWARD (pthread_cond_destroy, (pthread_cond_t *cond), (cond), 0)
FORWARD (pthread_cond_signal, (pthread_cond_t *cond), (cond), 0)
FORWARD (pthread_cond_wait, (pthread_cond_t *cond, pthread_mutex_t *mutex),
(cond, mutex), 0)
diff --git a/htl/pt-initialize.c b/htl/pt-initialize.c
index 051bc09e94..1b147b947a 100644
--- a/htl/pt-initialize.c
+++ b/htl/pt-initialize.c
@@ -28,7 +28,6 @@
#if IS_IN (libpthread)
static const struct pthread_functions pthread_functions = {
.ptr_pthread_cond_broadcast = __pthread_cond_broadcast,
- .ptr_pthread_cond_destroy = __pthread_cond_destroy,
.ptr_pthread_cond_signal = __pthread_cond_signal,
.ptr_pthread_cond_wait = __pthread_cond_wait,
.ptr_pthread_cond_timedwait = __pthread_cond_timedwait,