aboutsummaryrefslogtreecommitdiff
path: root/htl
diff options
context:
space:
mode:
authorgfleury <gfleury@disroot.org>2024-12-19 22:37:20 +0200
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2024-12-22 23:34:27 +0100
commit8735ea79ab22cad3bd975b507fd6ca4b37094bb8 (patch)
treee8da52c53c7dd0ac6a8e643c99d4a9381d3d47c8 /htl
parentassert/test-assert-2.c: Include <unistd.h> (diff)
downloadglibc-8735ea79ab22cad3bd975b507fd6ca4b37094bb8.tar.gz
glibc-8735ea79ab22cad3bd975b507fd6ca4b37094bb8.tar.bz2
glibc-8735ea79ab22cad3bd975b507fd6ca4b37094bb8.zip
htl: move pthread_cond_init into libc.
Signed-off-by: gfleury <gfleury@disroot.org> Message-ID: <20241219203727.669825-2-gfleury@disroot.org>
Diffstat (limited to 'htl')
-rw-r--r--htl/Makefile2
-rw-r--r--htl/Versions4
-rw-r--r--htl/forward.c3
-rw-r--r--htl/pt-initialize.c1
4 files changed, 4 insertions, 6 deletions
diff --git a/htl/Makefile b/htl/Makefile
index 7f40fd91bf..8dee043975 100644
--- a/htl/Makefile
+++ b/htl/Makefile
@@ -92,7 +92,6 @@ libpthread-routines := \
pt-rwlock-timedwrlock \
pt-rwlock-unlock \
pt-cond-destroy \
- pt-cond-init \
pt-cond-brdcast \
pt-cond-signal \
pt-cond-wait \
@@ -197,6 +196,7 @@ routines := \
pt-attr-setstackaddr \
pt-attr-setstacksize \
pt-cond \
+ pt-cond-init \
pt-condattr-destroy \
pt-condattr-getclock \
pt-condattr-getpshared \
diff --git a/htl/Versions b/htl/Versions
index dd786f7947..02d655d6bd 100644
--- a/htl/Versions
+++ b/htl/Versions
@@ -26,6 +26,7 @@ libc {
pthread_attr_setscope;
pthread_attr_setschedparam;
pthread_attr_init;
+ pthread_cond_init;
pthread_condattr_getclock;
pthread_condattr_init;
pthread_condattr_destroy;
@@ -94,6 +95,7 @@ libc {
__pthread_attr_setstacksize;
__pthread_attr_setstackaddr;
__pthread_attr_setstack;
+ __pthread_cond_init;
__pthread_condattr_init;
__pthread_default_condattr;
__pthread_sigstate;
@@ -133,7 +135,7 @@ libpthread {
pthread_cancel;
- pthread_cond_broadcast; pthread_cond_destroy; pthread_cond_init;
+ pthread_cond_broadcast; pthread_cond_destroy;
pthread_cond_signal; pthread_cond_timedwait; pthread_cond_wait;
pthread_create; pthread_detach; pthread_exit;
diff --git a/htl/forward.c b/htl/forward.c
index 48825de0b0..eb83eaeda1 100644
--- a/htl/forward.c
+++ b/htl/forward.c
@@ -55,9 +55,6 @@ name decl \
FORWARD (pthread_cond_broadcast, (pthread_cond_t *cond), (cond), 0)
FORWARD (pthread_cond_destroy, (pthread_cond_t *cond), (cond), 0)
-FORWARD (pthread_cond_init,
- (pthread_cond_t *cond, const pthread_condattr_t *cond_attr),
- (cond, cond_attr), 0)
FORWARD (pthread_cond_signal, (pthread_cond_t *cond), (cond), 0)
FORWARD (pthread_cond_wait, (pthread_cond_t *cond, pthread_mutex_t *mutex),
(cond, mutex), 0)
diff --git a/htl/pt-initialize.c b/htl/pt-initialize.c
index ae721f3a13..051bc09e94 100644
--- a/htl/pt-initialize.c
+++ b/htl/pt-initialize.c
@@ -29,7 +29,6 @@
static const struct pthread_functions pthread_functions = {
.ptr_pthread_cond_broadcast = __pthread_cond_broadcast,
.ptr_pthread_cond_destroy = __pthread_cond_destroy,
- .ptr_pthread_cond_init = __pthread_cond_init,
.ptr_pthread_cond_signal = __pthread_cond_signal,
.ptr_pthread_cond_wait = __pthread_cond_wait,
.ptr_pthread_cond_timedwait = __pthread_cond_timedwait,