summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-08-29 22:58:50 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-08-03 18:26:27 +0200
commit6e71d8930411588dfe6a629218b8aa3057f63658 (patch)
tree3ede11f25dc7a4ae0b10952aaae1df342588ea34
parent[no-patch] Gentoo: Add support files (diff)
downloadglibc-6e71d8930411588dfe6a629218b8aa3057f63658.tar.gz
glibc-6e71d8930411588dfe6a629218b8aa3057f63658.tar.bz2
glibc-6e71d8930411588dfe6a629218b8aa3057f63658.zip
Revert " * sysdeps/posix/getaddrinfo.c (gaih_inet): Only use gethostbyname4_r"
This reverts commit 8479f23aa1d5e5477a37f46823856bdafaedfa46. See for the background https://sourceware.org/bugzilla/show_bug.cgi?id=16826 https://bugs.gentoo.org/show_bug.cgi?id=600632 This makes test resolv/tst-res_use_inet6 fail. Disable it. (cherry picked from commit 06a2a073a2c6fb3e1489af96e125daca248d0a03)
-rw-r--r--resolv/Makefile1
-rw-r--r--sysdeps/posix/getaddrinfo.c9
2 files changed, 2 insertions, 8 deletions
diff --git a/resolv/Makefile b/resolv/Makefile
index ea395ac3eb..55fb992632 100644
--- a/resolv/Makefile
+++ b/resolv/Makefile
@@ -49,7 +49,6 @@ tests += \
tst-ns_name_pton \
tst-res_hconf_reorder \
tst-res_hnok \
- tst-res_use_inet6 \
tst-resolv-basic \
tst-resolv-binary \
tst-resolv-edns \
diff --git a/sysdeps/posix/getaddrinfo.c b/sysdeps/posix/getaddrinfo.c
index 553833d1f2..ae714e657b 100644
--- a/sysdeps/posix/getaddrinfo.c
+++ b/sysdeps/posix/getaddrinfo.c
@@ -756,13 +756,8 @@ gaih_inet (const char *name, const struct gaih_service *service,
while (!no_more)
{
no_data = 0;
- nss_gethostbyname4_r fct4 = NULL;
-
- /* gethostbyname4_r sends out parallel A and AAAA queries and
- is thus only suitable for PF_UNSPEC. */
- if (req->ai_family == PF_UNSPEC)
- fct4 = __nss_lookup_function (nip, "gethostbyname4_r");
-
+ nss_gethostbyname4_r fct4
+ = __nss_lookup_function (nip, "gethostbyname4_r");
if (fct4 != NULL)
{
while (1)