aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXi Ruoyao <xry111@xry111.site>2025-01-26 00:48:27 +0800
committerAndreas K. Hüttel <dilfridge@gentoo.org>2025-01-26 16:15:38 +0100
commitb31ed9581ba5f478343e2a60686e8dd34c57e68d (patch)
treee6542318a556c149d5523e38aedc319d66cd55b9
parentelf: fix 'valgrind' typo in comment (diff)
downloadglibc-b31ed9581ba5f478343e2a60686e8dd34c57e68d.tar.gz
glibc-b31ed9581ba5f478343e2a60686e8dd34c57e68d.tar.bz2
glibc-b31ed9581ba5f478343e2a60686e8dd34c57e68d.zip
testsuite: Make stdio-common/tst-printf-format-*-mem UNSUPPORTED if the mtrace output does not exist
When gawk was not built with MPFR, there's no mtrace output and those tests FAIL. But we should make them UNSUPPORTED like other tst-printf-format-* tests in the case. Signed-off-by: Xi Ruoyao <xry111@xry111.site> Reviewed-by: Sam James <sam@gentoo.org> Reviewed-by: Andreas K Hüttel <dilfridge@gentoo.org>
-rw-r--r--stdio-common/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/stdio-common/Makefile b/stdio-common/Makefile
index bbdc1ff709..840289afd9 100644
--- a/stdio-common/Makefile
+++ b/stdio-common/Makefile
@@ -599,8 +599,11 @@ $(objpfx)tst-%-mem.out: $(objpfx)tst-%.out
$(common-objpfx)malloc/mtrace $(objpfx)tst-$*.mtrace > $@; \
$(evaluate-test)
$(objpfx)tst-printf-format-%-mem.out: $(objpfx)tst-printf-format-%.out
- $(common-objpfx)malloc/mtrace \
- $(objpfx)tst-printf-format-$*.mtrace > $@; \
+ { test -r $(objpfx)tst-printf-format-$*.mtrace \
+ || ( echo "$(objpfx)tst-printf-format-$*.mtrace does not exist"; \
+ exit 77; ) \
+ && $(common-objpfx)malloc/mtrace \
+ $(objpfx)tst-printf-format-$*.mtrace; } > $@; \
$(evaluate-test)
errlist-h = $(firstword $(wildcard $(addsuffix /errlist.h,$(sysdirs) .)))