diff options
author | Gabriel F. T. Gomes <gabrielftg@linux.ibm.com> | 2019-10-08 14:32:17 -0300 |
---|---|---|
committer | Andreas K. Hüttel <dilfridge@gentoo.org> | 2019-11-25 23:00:53 +0100 |
commit | bb5c615e932b59fff8793cfb6666dc300d48cea2 (patch) | |
tree | 97a136227159db6943bac041d23c206ed88495e7 | |
parent | S390: Add new s390 platform z15. (diff) | |
download | glibc-bb5c615e932b59fff8793cfb6666dc300d48cea2.tar.gz glibc-bb5c615e932b59fff8793cfb6666dc300d48cea2.tar.bz2 glibc-bb5c615e932b59fff8793cfb6666dc300d48cea2.zip |
Make tst-strftime2 and tst-strftime3 depend on locale generation
Building the test cases in parallel might make tst-strftime2 and
tst-strftime3 fail. Simply re-running the test case (or building
serially) makes the problem go away. This patch adds the necessary
dependency to allow parallel builds in the time subdirectory.
Tested for powerpc64le.
Reviewed-by: Florian Weimer <fweimer@redhat.com>
Reviewed-by: Tulio Magno Quites Machado Filho <tuliom@linux.ibm.com>
(cherry picked from commit 52151051b39293dac9fc3181cfd6240d7ce86ca1)
(cherry picked from commit fca2d6186af873cb8355e216c07f4b4874ec5d3a)
-rw-r--r-- | ChangeLog | 6 | ||||
-rw-r--r-- | time/Makefile | 2 |
2 files changed, 8 insertions, 0 deletions
@@ -1,3 +1,9 @@ +2019-10-08 Gabriel F. T. Gomes <gabrielftg@linux.ibm.com> + + * Makefile: Fix locale dependency for a couple of tests. + ($(objpfx)tst-strftime2.out): New rule. + ($(objpfx)tst-strftime3.out): Likewise. + 2019-09-20 Joseph Myers <joseph@codesourcery.com> * sysdeps/unix/sysv/linux/riscv/vfork.S: Do not include diff --git a/time/Makefile b/time/Makefile index a428f55245..63b8d735ea 100644 --- a/time/Makefile +++ b/time/Makefile @@ -57,6 +57,8 @@ include ../gen-locales.mk $(objpfx)tst-ftime_l.out: $(gen-locales) $(objpfx)tst-strptime.out: $(gen-locales) +$(objpfx)tst-strftime2.out: $(gen-locales) +$(objpfx)tst-strftime3.out: $(gen-locales) endif tz-cflags = -DTZDIR='"$(zonedir)"' \ |