aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Weimer <fweimer@redhat.com>2019-08-15 16:09:05 +0200
committerAndreas K. Huettel <dilfridge@gentoo.org>2020-03-09 11:44:51 +0100
commit10e3ceaee0a3944f73307390cf90ba8568e2da87 (patch)
treef571b4ec32500ad65bf5fa9277b01c4c05c29f51
parentlogin: Fix updwtmp, updwtmx unlocking (diff)
downloadglibc-10e3ceaee0a3944f73307390cf90ba8568e2da87.tar.gz
glibc-10e3ceaee0a3944f73307390cf90ba8568e2da87.tar.bz2
glibc-10e3ceaee0a3944f73307390cf90ba8568e2da87.zip
login: Disarm timer after utmp lock acquisition [BZ #24879]
If the file processing takes a long time for some reason, SIGALRM can arrive while the file is still being processed. At that point, file access will fail with EINTR. Disarming the timer after lock acquisition avoids that. (If there was a previous alarm, it is the responsibility of the caller to deal with the EINTR error.) (cherry picked from commit 628598be7e1bfaa04f34df71ef6678f2c5103dfd) (cherry picked from commit 8baeebad9aa6eca0eba028a9c95cd0867b37aa2d)
-rw-r--r--ChangeLog13
-rw-r--r--NEWS1
-rw-r--r--login/utmp_file.c80
3 files changed, 42 insertions, 52 deletions
diff --git a/ChangeLog b/ChangeLog
index d734a35b5b..4a89e56249 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,18 @@
2019-08-15 Florian Weimer <fweimer@redhat.com>
+ [BZ #24879]
+ login: Disarm timer after utmp lock acquisition.
+ * login/utmp_file.c (struct file_locking): Remove.
+ (try_file_lock): Adjust.
+ (file_lock_restore): Remove function.
+ (__libc_getutent_r): .
+ (internal_getut_r): Likewise.
+ (__libc_getutline_r): Likewise.
+ (__libc_pututline): Likewise.
+ (__libc_updwtmp): Likewise.
+
+2019-08-15 Florian Weimer <fweimer@redhat.com>
+
* login/utmp_file.c (__libc_updwtmp): Unlock the right file
descriptor.
* login/Makefile (tests): Add tst-updwtmpx.
diff --git a/NEWS b/NEWS
index 4d26e01248..96458cf0b9 100644
--- a/NEWS
+++ b/NEWS
@@ -21,6 +21,7 @@ The following bugs are resolved with this release:
[24682] localedata: zh_CN first weekday should be Monday per GB/T
7408-2005
[24867] malloc: Remove unwanted leading whitespace in malloc_info
+ [24879] login: Disarm timer after utmp lock acquisition
[24986] alpha: new getegid, geteuid and getppid syscalls used
unconditionally
[25189] Don't use a custom wrapper macro around __has_include
diff --git a/login/utmp_file.c b/login/utmp_file.c
index 5e4e66d1d0..f3c528384f 100644
--- a/login/utmp_file.c
+++ b/login/utmp_file.c
@@ -55,32 +55,23 @@ static void timeout_handler (int signum) {};
/* try_file_lock (LOCKING, FD, TYPE) returns true if the locking
operation failed and recovery needs to be performed.
- (file_lock_restore (LOCKING) still needs to be called.)
file_unlock (FD) removes the lock (which must have been
- acquired).
-
- file_lock_restore (LOCKING) is needed to clean up in both
- cases. */
-
-struct file_locking
-{
- struct sigaction old_action;
- unsigned int old_timeout;
-};
+ successfully acquired). */
static bool
-try_file_lock (struct file_locking *locking, int fd, int type)
+try_file_lock (int fd, int type)
{
/* Cancel any existing alarm. */
- locking->old_timeout = alarm (0);
+ int old_timeout = alarm (0);
/* Establish signal handler. */
+ struct sigaction old_action;
struct sigaction action;
action.sa_handler = timeout_handler;
__sigemptyset (&action.sa_mask);
action.sa_flags = 0;
- __sigaction (SIGALRM, &action, &locking->old_action);
+ __sigaction (SIGALRM, &action, &old_action);
alarm (TIMEOUT);
@@ -90,7 +81,23 @@ try_file_lock (struct file_locking *locking, int fd, int type)
.l_type = type,
fl.l_whence = SEEK_SET,
};
- return __fcntl64_nocancel (fd, F_SETLKW, &fl) < 0;
+
+ bool status = __fcntl64_nocancel (fd, F_SETLKW, &fl) < 0;
+ int saved_errno = errno;
+
+ /* Reset the signal handler and alarm. We must reset the alarm
+ before resetting the handler so our alarm does not generate a
+ spurious SIGALRM seen by the user. However, we cannot just set
+ the user's old alarm before restoring the handler, because then
+ it's possible our handler could catch the user alarm's SIGARLM and
+ then the user would never see the signal he expected. */
+ alarm (0);
+ __sigaction (SIGALRM, &old_action, NULL);
+ if (old_timeout != 0)
+ alarm (old_timeout);
+
+ __set_errno (saved_errno);
+ return status;
}
static void
@@ -103,21 +110,6 @@ file_unlock (int fd)
__fcntl64_nocancel (fd, F_SETLKW, &fl);
}
-static void
-file_lock_restore (struct file_locking *locking)
-{
- /* Reset the signal handler and alarm. We must reset the alarm
- before resetting the handler so our alarm does not generate a
- spurious SIGALRM seen by the user. However, we cannot just set
- the user's old alarm before restoring the handler, because then
- it's possible our handler could catch the user alarm's SIGARLM
- and then the user would never see the signal he expected. */
- alarm (0);
- __sigaction (SIGALRM, &locking->old_action, NULL);
- if (locking->old_timeout != 0)
- alarm (locking->old_timeout);
-}
-
#ifndef TRANSFORM_UTMP_FILE_NAME
# define TRANSFORM_UTMP_FILE_NAME(file_name) (file_name)
#endif
@@ -166,8 +158,7 @@ __libc_getutent_r (struct utmp *buffer, struct utmp **result)
return -1;
}
- struct file_locking fl;
- if (try_file_lock (&fl, file_fd, F_RDLCK))
+ if (try_file_lock (file_fd, F_RDLCK))
nbytes = 0;
else
{
@@ -175,7 +166,6 @@ __libc_getutent_r (struct utmp *buffer, struct utmp **result)
nbytes = __read_nocancel (file_fd, &last_entry, sizeof (struct utmp));
file_unlock (file_fd);
}
- file_lock_restore (&fl);
if (nbytes != sizeof (struct utmp))
{
@@ -201,11 +191,9 @@ internal_getut_r (const struct utmp *id, struct utmp *buffer,
{
int result = -1;
- struct file_locking fl;
- if (try_file_lock (&fl, file_fd, F_RDLCK))
+ if (try_file_lock (file_fd, F_RDLCK))
{
*lock_failed = true;
- file_lock_restore (&fl);
return -1;
}
@@ -257,7 +245,6 @@ internal_getut_r (const struct utmp *id, struct utmp *buffer,
unlock_return:
file_unlock (file_fd);
- file_lock_restore (&fl);
return result;
}
@@ -303,11 +290,9 @@ __libc_getutline_r (const struct utmp *line, struct utmp *buffer,
return -1;
}
- struct file_locking fl;
- if (try_file_lock (&fl, file_fd, F_RDLCK))
+ if (try_file_lock (file_fd, F_RDLCK))
{
*result = NULL;
- file_lock_restore (&fl);
return -1;
}
@@ -337,7 +322,6 @@ __libc_getutline_r (const struct utmp *line, struct utmp *buffer,
unlock_return:
file_unlock (file_fd);
- file_lock_restore (&fl);
return ((*result == NULL) ? -1 : 0);
}
@@ -394,12 +378,8 @@ __libc_pututline (const struct utmp *data)
}
}
- struct file_locking fl;
- if (try_file_lock (&fl, file_fd, F_WRLCK))
- {
- file_lock_restore (&fl);
- return NULL;
- }
+ if (try_file_lock (file_fd, F_WRLCK))
+ return NULL;
if (found < 0)
{
@@ -442,7 +422,6 @@ __libc_pututline (const struct utmp *data)
unlock_return:
file_unlock (file_fd);
- file_lock_restore (&fl);
return pbuf;
}
@@ -471,10 +450,8 @@ __libc_updwtmp (const char *file, const struct utmp *utmp)
if (fd < 0)
return -1;
- struct file_locking fl;
- if (try_file_lock (&fl, fd, F_WRLCK))
+ if (try_file_lock (fd, F_WRLCK))
{
- file_lock_restore (&fl);
__close_nocancel_nostatus (fd);
return -1;
}
@@ -504,7 +481,6 @@ __libc_updwtmp (const char *file, const struct utmp *utmp)
unlock_return:
file_unlock (fd);
- file_lock_restore (&fl);
/* Close WTMP file. */
__close_nocancel_nostatus (fd);